Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Info needed] 3 years ago I got stuck entering Ardoris

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Sly Hunter, Mar 27, 2018.

Thread Status:
Not open for further replies.
  1. Elwyn

    Elwyn Avatar

    Messages:
    3,482
    Likes Received:
    4,653
    Trophy Points:
    153
    Gender:
    Male
    Location:
    San Antonio, TX
    Just a hunch, but how big is your power supply? How many watts? If it is 400W or less you should probably get a bigger one. However, when that happened to me years ago, the whole computer shut down after about 45-60 seconds in SotA.

    At least 12GB of RAM is strongly recommended, and 16GB is a really good idea. At least a 2GB video card is probably also a good idea.

    I'm running fine on a years-old i5 with 12GB of RAM and a $110 GT 1030 that I got two months ago. But I got a 600W power supply at the same time. (original power supply was 225W)
     
  2. Sly Hunter

    Sly Hunter Avatar

    Messages:
    47
    Likes Received:
    12
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Florida
    OK, now I have a complaint, relative to my problem.
    You went live and advertised on Stream. The minimum system requirements my system meets. It says nothing about gpu.

    I'll be waiting until I have 16gb 3.4mhz computer to play the game with.
    I played Ultima 1 when it was brand new and all the Ultima's thereafter.
     
Thread Status:
Not open for further replies.