Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Poor performance and memory leaks

Discussion in 'Release 3 Feedback' started by enderandrew, Feb 21, 2014.

Thread Status:
Not open for further replies.
  1. Doppelganger [MGT]

    Doppelganger [MGT] Avatar

    Messages:
    496
    Likes Received:
    1,201
    Trophy Points:
    55
    Gender:
    Male
    Location:
    Tampa Bay, FL
    Did you see this Caliya? This may help a bit in the meantime :) Pre-optimization performance suggestions
     
    Time Lord likes this.
  2. Caliya

    Caliya Avatar

    Messages:
    1,379
    Likes Received:
    2,326
    Trophy Points:
    113
    Gender:
    Female
    Location:
    US Midwest
    Yes, I saw it.

    Windows 7, 64 bit, AMD FX 4100 Quad-Core, 8 GB RAM (plan to upgrade to 16), AMD Radeon HD 6800. Our Internet service is Comcast Cable and my speed test is slower than the service I pay for, but download clocks at 26 Mbps. I was not running any other applications. I closed everything. I ran at "fastest" as recommended, full screen. Did not have a 2nd monitor (who does this??). In addition, I uninstalled my previous versions of SotA (included any saved files), rebooted my PC, and downloaded a fresh version.

    My PC is a little more than 2 years old, but has more than ample hardware for a game of this nature. I can run every modern, fully developed game on this PC, without any problems whatsoever.

    There were countless times I couldn't even connect to the game. In multi-player, the longest I ever managed to stay connected was 7 minutes. The least, a few seconds (if I could log in at all). It didn't seem to matter if I was in a populated tavern or no one else was around. When I was in single player, it played about the same as R1 and R2. I could stay connected for roughly 15 minutes at a time, but often less. I was afraid to click on things because it usually crashed me. Adding friends, opening chests, opening doors, all crashed me (not immediately everytime but often within seconds afterwards).
     
  3. Sanctius

    Sanctius Avatar

    Messages:
    104
    Likes Received:
    107
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Finland
    I'm running i5 2500k, 8Gb, SSD, GTX680 and the game is really choppy for me. I can run TSW, FF:ARR etc max.

    I don't mind but i also won't be testing the game more than a few minutes at a time till i get this running smoother in the future releases since it gives me a headache to see such low frame rates. Hope people enjoyed it so far still.
     
  4. Sunsanvil

    Sunsanvil Avatar

    Messages:
    308
    Likes Received:
    593
    Trophy Points:
    43
    I find these threads interesting because my experience is NOTHING like the OP's.

    I played this past weekend at 1920x1200 with all sliders maxed and while it was a little choppy compared to PA2, it was what I would expect for an unoptomised test build. I even left myself logged in for a couple hours and no leaks, no crashes, no problems.

    i5-3570
    Radeon HD7850 2GB
    8GB DDR3 1600Mhz
    Windows 8.1
     
    Doppelganger likes this.
  5. Doppelganger [MGT]

    Doppelganger [MGT] Avatar

    Messages:
    496
    Likes Received:
    1,201
    Trophy Points:
    55
    Gender:
    Male
    Location:
    Tampa Bay, FL
    Same here really. It was definitely choppier than R2, but that was to be expected with the first test of multi-player. Overall, it needs a lot of optimization but I was neither shocked or overly disappointed by what I experienced. I'm sure it will run 100% better by release (I hope)

    I am running AMD 8350
    8GB DDR1866
    Radeon 7870 2GB
    Win 7 sp1
     
    Time Lord likes this.
  6. klepp0906

    klepp0906 Avatar

    Messages:
    8
    Likes Received:
    6
    Trophy Points:
    3
    i7 4970k - 64gb pc2400 - gtx titan x4 - runs abysmally. Why? because I play at 4680x2560 and its using only 1 card. GG until it gets fixed. Im amazed they can create a game in 2015 without multicore or sli support lol. I wish I would have known before purchase as at this point its all but useless and unplayable to me. Not going to disconnect monitors and modify my pc just to play.

    If they implement a real "full screen" mode then SLI should work even if rudimentarely via a modified profile.
     
Thread Status:
Not open for further replies.