Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Mac client R10

Discussion in 'Release 10 Feedback' started by Michael Jung, Sep 28, 2014.

Thread Status:
Not open for further replies.
  1. Michael Jung

    Michael Jung Avatar

    Messages:
    20
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Mainz
    I couldn't much do in game as the mac client froze or crashed way too often or got stuck somewhere.
    No chance to fight or do quests properly. At some point I got very frustrated and gave up.

    Entering a scene/town can take up to 2min, quite often got stuck here at "Building maps ...".
    Mouse / keyboard control of char feels very inaccurate.
    Moving on over world / map is not easy.
    Sometimes the game "ate" my mouse and cursor disappeared, mostly game froze then.
    On Mac Sounds, Music are way too loud.

    Think about installing windows version with wine/crossover and test.

    Mac Pro 2008 / 32 GB / ATI 5870 1GB / 1 TB SSD / OS X Mavericks / Internet 16 MB
     
  2. Tizon

    Tizon Avatar

    Messages:
    29
    Likes Received:
    30
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Corpus Christi, Texas
    I have a mac 2.5ghz 8gig and I was having troubles too. It had the same symptoms as yours ... I switched the video settings over to "fastest" and had noticeably better performance with fewer crashes.
     
  3. RuvalSioned

    RuvalSioned Avatar

    Messages:
    7
    Likes Received:
    12
    Trophy Points:
    3
    I am with you on this one. I tried to play on my Mac and just gave up.. the client is way to unstable. It appears from my perspective to be most likely to crash during loads. Just sits there and crashes. I have to kill the process.

    My feeling is they should work on the Windows version first and not try and bite more then they can chew. I have had nothing but bad experiences trying to test the Alpha's on the Mac.

    Imac 27inch i5 3.4 Ghz / 8GB memory/ OS 10.8.5 / Nvidia 775M 2048 MB

    Ruval
     
  4. smack

    smack Avatar

    Messages:
    7,081
    Likes Received:
    15,294
    Trophy Points:
    153
    Yeah this is the first release where I'm not really able to play on my mid-2012 Retina MBP, even with the graphics kicked down to Fastest, no shadows, no AO, etc. At least in OPO mode. I can jump in with SPO without any probs so far, but I haven't been to all locations like Ardoris yet.

    In OPO mode, I get the SPOD during loading screens.

    EDIT: Heh, I just tested going to Ardoris and it's stuck at the loading screen. :)
     
  5. Beaumaris

    Beaumaris Avatar

    Messages:
    4,233
    Likes Received:
    7,348
    Trophy Points:
    165
    Gender:
    Male
    Location:
    Caladruin
    I played on an IMac 3.2 Ghtz 8 GB Ram GF 775M. On fastest setting, the game ran fine and did not crash to desktop. My largest issue was that the game zoning screens between would freeze a fair number of times.
     
  6. Michael Jung

    Michael Jung Avatar

    Messages:
    20
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Mainz
    The biggest problem for me was zoning: leaving a city or entering. As I said it took way too long and client froze.
    Finally I realized that unfocusing the game window (dual monitor: going to a browser or reading email ) raised the chance to get stuck to nearly 100%.

    I made some progress and played another 2 hrs today, even got the special hat, but I had to be extremely patient - nevertheless 2 times froze the client while zoning.

    In the end I must admit that I was quite unhappy how the game feels, reacts and that there is no real control over a characters movement and the camera.
    From my view a Beta this year is impossible, for me the game lacks to much to really immerse.
     
  7. quickquests

    quickquests Avatar

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I can play.. i must restart often... I had read someone had played on the same specs as myself and had their settings set to beautiful... i cannot even walk around with anything but "fastest" and lowered resolution to the minimum available.



    iMac 27-inch Late 2012 (2560 x 1440)
    NVIDIA GeForce GTX 680MX 2048 MB
    8 GB 1600 MHz DDR3
    3,2 GHz Intel Core i5
    OS X 10.9.2 (13C64)
     
Thread Status:
Not open for further replies.