1. This forum is for bug reporting of current Live Game Server issues ONLY.
    Be sure to follow the format below, it will help us out greatly in responding. If you do not, your report may not be entered into the system.

    Read BEFORE submitting your first bug: Reporting Bugsā€¦ QA 101 Document
    • Search for your bug in all likely categories before posting in order to avoid duplicate reports.
    • Be sure to provide details of what the issue is and how to re-produce it, but keep your bug report factual.
    • Reply to an existing thread if you have additional information for the reported bug.
      Do not use this forum for commentary, your post will be deleted and you may be moderated, suspended or banned if the activity continues.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    NOTE: Important information including your location and system specs are automatically put into your clipboard when using /bug in the game (DO NOT add additional system specs unless requested). When starting your post, just use <CTRL>-V to insert the data and fill in the entries with no data.

    Please include Screenshots if possible. Images can be saved on our SotA Discord Server here

    If the clipboard does not work, use and fill in this Bug Report Template:
    1. Title:
    2. Reproducible?
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs: (RAM, CPU, GPU and Operating System only)
    Dismiss Notice

[Submitted 68712] AFK disconnects while idle on a lot, basement, dungeon, or POT that you own

Discussion in 'Player Owned Towns & Player Housing' started by nimueCW, Feb 1, 2021.

  1. nimueCW

    nimueCW Avatar

    Messages:
    108
    Likes Received:
    194
    Trophy Points:
    18
    02/01/2021 15:51
    Title: AFK timer doesn't seem to be working correctly
    Reproduction Rate:100%
    Blocker? no, but annoying
    Details:When I have to leave for a length of time, I will go hang in the basement on my lot. Before the AFK changes, it would take a while before the afk auto sit and even longer before it would do an idle disconnect. ( at least more than half an hour for the whole process) Now it sits after just a couple of minutes and idle disconnects in shorter than half an hour. All I am during that time is standing there.
    Steps to Reproduce: Go into basement and wait
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-3820 CPU @ 3.60GHz (8) System RAM: 20457
    GPU: NVIDIA GeForce GTX 750 Ti GPU RAM: 2007
    SotA.Win.64.1340.Date.01.29.21
    Area: BasementSceneDungeonVillage_2Floor
    Area Display Name: Village Stone 2-Story Basement
    Loc: (10.6, 5.0, 6.6)
    Debug: QmFzZW1lbnRTY2VuZUR1bmdlb25WaWxsYWdlXzJGbG9vcnx8KDEwLjU1MywgNS4wMTEsIDYuNjEyKXwoMCwgMC44NjUsIDAsIC0wLjUwMSl8LTExMC4yMTAxfDI3LjQ4MzYzfDMuMDcyMjg0
     
    AzazelReborn likes this.
  2. AzazelReborn

    AzazelReborn Avatar

    Messages:
    207
    Likes Received:
    263
    Trophy Points:
    18
    I have the same problem.
     
    nimueCW likes this.
  3. Raven Swiftbow

    Raven Swiftbow Bug Hunter

    Messages:
    1,097
    Likes Received:
    2,242
    Trophy Points:
    125
    Gender:
    Female
    Location:
    Louisiana
    Definitely. It's like it "lost" what Chris had put in. We now time out like we did before.

    *goes back to doing the Gypsy Dance while I run to shift the clothes from the washing machine to the dryer*
     
    Last edited: Feb 7, 2021
    nimueCW likes this.
  4. nimueCW

    nimueCW Avatar

    Messages:
    108
    Likes Received:
    194
    Trophy Points:
    18

    Sadly its even shorter than before. I could go in my basement for the half hour it took to pick up the kid from school and be fine. Since the change, I get kicked before I get back :(
     
  5. Dysis

    Dysis Avatar

    Messages:
    78
    Likes Received:
    86
    Trophy Points:
    8
    I have been fine till today. Was booted 6 times before noon in brit estates, and I was not using or gaining exp.

    Giving up, think im up to 9 times now. It seems to boot you faster than the old afk timer.

    Edit: This is unrelenting. I think we accidentally put in a bizarro afk timer! I dont think even superman can help us now!
     
    Last edited: Feb 17, 2021
  6. Anpu

    Anpu Bug Hunter

    Messages:
    5,777
    Likes Received:
    6,475
    Trophy Points:
    153
    Location:
    Pacific Northwest
    I finally got to see this happening yesterday, was just trying to see this happen. I had my character stand on the bottom floor of my village home. I waited the 10 minutes and then the character was turned to AFK. I then left my character there and then walked to the store to go pick up some stuff. Of note my character is doing nothing. When I returned home I had the ROMEUS error and my character was logged out. So standing in your home, doing completely nothing, will eventually log you out when you go AFK.
     
    nimueCW likes this.
  7. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    3,029
    Likes Received:
    3,482
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    Is this only happening while on a player lot that you own, or anything specific like that? Ie: ground floor, basement, roof, etc?

    Testing on ground floor on a lot I own:

    I'm @ 21 minutes standing on the ground floor of a lot (on a slow laptop).. but I am alt-tabbing to check occasionally, and I think that was resetting the timer.. switching to basement to see if that makes a difference.

    Testing in my basement

    Update: Looks like alt-tab does reset the clock..I stood up when I alt-tabbed back into SOTA.. so I'm using the Aero Preview or Peek or whatever Microsoft calls it to hover over SOTA occasionally and check what's up.. I appeared to have sat down after ~ 10 minutes, and when I alt-tabbed to double check, I stood up.. so now I'm going to reset my stop watch and time it some more, to see how long till disconnect.

    Update: 2nd time took about ~12.5 minutes to sit down.. Now I'm waiting to see if/when I get disconnected.

    Update: I got disconnected, and stopwatch was at 33 minutes - it probably happened around 30 minutes or so, but I was distracted by TV.

    Testing on my roof

    Update: ~21-22 minutes, not sitting yet.
    Update: ~22.5 minutes, disconnected. I never saw my character sit.. weird..

    ---------------------------

    Not sure what the timer(s) were prior to the changes - so I'm going to change the thread title to "Still being disconnected while idle" and mark it verified.
     
    Last edited: Feb 8, 2021
    Anpu likes this.
  8. Anpu

    Anpu Bug Hunter

    Messages:
    5,777
    Likes Received:
    6,475
    Trophy Points:
    153
    Location:
    Pacific Northwest
    When I went to to near by crafting pavilion lot NOT owned by me, I stood in the area till I went AFK. then waited. There I didn't get booted off.

    This might be happening only on lots you own?
     
  9. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    3,029
    Likes Received:
    3,482
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    That is also a suspicion I had, but I couldn't test it last night (needed to sleep). I'm going to leave the client idle while doing work stuff this morning on someone else's lot, and see what happens..

    1 hour 6 minutes - standing outside an NPC building in Northwood, and still connected.. sat down after about 20 (I went to take a shower, so was probably less)
    .. updating the title tentatively to reflect this.. next step is to test on a lot I don't own..

    Tested on another POT lot (without the owner present) and am still connected (but sitting) after ~ 57 minutes.
     
    Last edited: Feb 9, 2021
    Anpu likes this.
  10. nimueCW

    nimueCW Avatar

    Messages:
    108
    Likes Received:
    194
    Trophy Points:
    18
    I have only noticed it while in the basement of a lot I own, but I rarely go afk anywhere else. The hubby was able to hang in one of our town devotionals with no issued so you may be on to something with it being a self owned lot. I will try it at a random spot in my POT when I have some time later today to see if that triggers it or not.
     
  11. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    3,029
    Likes Received:
    3,482
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    Cool.. I just tested in a POT with the Governor/Lot Owner present the entire time and was not disconnected..

    TLDR/Summary: . this seems isolated to being on a lot, basement, dungeon, or POT that you own.
     
    Last edited: Feb 10, 2021
    Anpu likes this.
  12. nimueCW

    nimueCW Avatar

    Messages:
    108
    Likes Received:
    194
    Trophy Points:
    18
    45 min in my pot, was sitting but still connected. Unless someone gets to it first, I can check with my dungeon after I get done for the evening.
     
    Echondas likes this.
  13. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    3,029
    Likes Received:
    3,482
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    Were you on a lot that you own?
     
  14. nimueCW

    nimueCW Avatar

    Messages:
    108
    Likes Received:
    194
    Trophy Points:
    18
    Not that time, I was in an unclaimed area, but since I own the POT was curious if it would count.
    I just tested in my dungeon and it kicked me same as the basement as expected. Looks like you are onto something with it being tied to lot ownership
     
    Echondas and Anpu like this.
  15. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    3,029
    Likes Received:
    3,482
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    Thanks - I updated the thread title and also moved the bug to the POT forum section.
     
    Last edited: Feb 10, 2021
    nimueCW likes this.
  16. Anpu

    Anpu Bug Hunter

    Messages:
    5,777
    Likes Received:
    6,475
    Trophy Points:
    153
    Location:
    Pacific Northwest
    This will also happen in Boreas Colossus. I entered the scene, stood next to Siksaka. I then did nothing, did not touch mouse or move. I was turned AFK. After a few minutes I was logged off and got the ROMEUS Error. A Player was mentioning this to me, so I thought I should check.

    02/12/2021 22:28
    Title:
    Reproduction Rate:
    Blocker?
    Details:
    Steps to Reproduce:
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Xeon(R) CPU E5-1620 0 @ 3.60GHz (8) System RAM: 16303
    GPU: NVIDIA GeForce GTX 1080 GPU RAM: 8079
    SotA.Win.64.1345.Date.02.10.21
    Area: Novia_R2_Hills01_01
    Area Display Name: Boreas Colossus
    Loc: (-99.0, 175.0, -9.6)
    Debug: Tm92aWFfUjJfSGlsbHMwMV8wMXx8KC05OC45ODksIDE3NSwgLTkuNjI3KXwoMCwgMC42NTksIDAsIDAuNzUzKXw4Mi4zODI2MnwxMHwxMy4wNDgx
     
  17. Dysis

    Dysis Avatar

    Messages:
    78
    Likes Received:
    86
    Trophy Points:
    8
    Booted 6 times today from my POT. I am going to try to go elsewhere and see if it boots me. Some good theories in here to test:)

    Edit: went to silverdale, not on my property, and I was booted just as quickly as the other 6 times today while i was in my POT not gaining or spending exp. Thank you.
     
    Last edited: Feb 16, 2021
  18. Justyn

    Justyn Bug Hunter Bug Moderator

    Messages:
    696
    Likes Received:
    630
    Trophy Points:
    93
    Submitted: Issue 68712
     
  19. Dysis

    Dysis Avatar

    Messages:
    78
    Likes Received:
    86
    Trophy Points:
    8
    I was afk all day in Brit wharfs, never had an issue. Then I went to my house in brit estates, and afk booted non stop on the dot. I am going to go back to wharfs and test one more time.
     
  20. Dysis

    Dysis Avatar

    Messages:
    78
    Likes Received:
    86
    Trophy Points:
    8
    Ok, i went back to wharfs, and got booted again. So my theory is wrong, however, the new afk timer rules are having a serious issue.