1. This forum is for bug reporting of current Live Game Server issues ONLY.
    Be sure to follow the format below, it will help us out greatly in responding. If you do not, your report may not be entered into the system.

    Read BEFORE submitting your first bug: Reporting Bugsā€¦ QA 101 Document
    • Search for your bug in all likely categories before posting in order to avoid duplicate reports.
    • Be sure to provide details of what the issue is and how to re-produce it, but keep your bug report factual.
    • Reply to an existing thread if you have additional information for the reported bug.
      Do not use this forum for commentary, your post will be deleted and you may be moderated, suspended or banned if the activity continues.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    NOTE: Important information including your location and system specs are automatically put into your clipboard when using /bug in the game (DO NOT add additional system specs unless requested). When starting your post, just use <CTRL>-V to insert the data and fill in the entries with no data.

    Please include Screenshots if possible. Images can be saved on our SotA Discord Server here

    If the clipboard does not work, use and fill in this Bug Report Template:
    1. Title:
    2. Reproducible?
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs: (RAM, CPU, GPU and Operating System only)
    Dismiss Notice

[Submitted 69309] Lord Founder Town Home causes pets to teleport

Discussion in 'Player Owned Towns & Player Housing' started by Aksarben, Jun 6, 2021.

  1. Sayge Raine

    Sayge Raine Bug Hunter

    Messages:
    25
    Likes Received:
    17
    Trophy Points:
    3
    06/06/2021 16:42
    Title: Hay Drying Rack causes pets and conversationalists to teleport off the property.
    Reproduction Rate: 100%
    Blocker?
    Details: Placing the Hay Drying Rack on a property causes pets and conversationalists to teleport off the property. For us they all teleport directly East to our property next door.
    Steps to Reproduce: Have pets on the lot and then place a Hay Drying Rack.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: AMD Ryzen 5 1400 Quad-Core Processor (8) System RAM: 16336
    GPU: Radeon RX 580 Series GPU RAM: 4075
    SotA.Win.64.1390.Date.06.03.21
    Area: PRT_forest_metropolis_01/Taenby Landing
    Area Display Name: Taenby Landing
    Loc: (-34.9, 37.0, -113.9)
    Debug: UFJUX2ZvcmVzdF9tZXRyb3BvbGlzXzAxfFRhZW5ieSBMYW5kaW5nfCgtMzQuOTM5LCAzNywgLTExMy44NzUpfCgwLCAwLjgwMSwgMCwgLTAuNTk5KXwtMTU0Ni4xOTl8MjAuMTc1NTN8NS44ODAxMjc=
     
  2. Alley Oop

    Alley Oop Bug Hunter Bug Moderator

    Messages:
    12,492
    Likes Received:
    17,417
    Trophy Points:
    153
    cannot verify. this item does not glitch out the deco pets on my property. if you can figure out a combination of deco that will do it reliably, please report back.
     
  3. Sayge Raine

    Sayge Raine Bug Hunter

    Messages:
    25
    Likes Received:
    17
    Trophy Points:
    3
    I took the rack to the property next door and placed it all around the lot. The pets "jumped" a little bit when I placed the Rack but did not leave the property completely. Maybe because there is not a house on the property has something to do with them glitching.


    EDIT: Did some more testing and found the following. If I place the Rack and then zone (either going it to a basement or dungeon or going to a different town and coming back the pets are on the property. As they start their roaming when they get near the rack they teleport out one by one.
    Also, if I move the rack around after porting and the pets are all back on the property then they will bounce to the other property.

    I will gladly show anyone who wants to see this if they come to the property.
     
    Last edited: Jun 6, 2021
  4. Sayge Raine

    Sayge Raine Bug Hunter

    Messages:
    25
    Likes Received:
    17
    Trophy Points:
    3
    Something is going on. The pets are teleporting to the other lot whenever I run from one lot to the other, zone in to the lot from basement, dungeon or other towns/overworld. As you can see in the screenshot I have 8 pets on a 6 pet lot. The pets from the Town sized lot do not teleport to the village lot only the other way around.
    [​IMG]
     
  5. Alley Oop

    Alley Oop Bug Hunter Bug Moderator

    Messages:
    12,492
    Likes Received:
    17,417
    Trophy Points:
    153
    @Aksarben, i believe you that SOMETHING is happening.

    "that will do it reliably" means a combo that i (or anyone else) can go and test elsewhere and will still glitch out the same way. i tested the hay rack when you reported it. it was fine. it was ALSO previously tested when the other hay decorations were reported. it was fine then, too. i just now tested again it on a lot completely empty of anything but the rack and two llamas. it's fine. i think you need to look at something other than the rack.
     
  6. Sayge Raine

    Sayge Raine Bug Hunter

    Messages:
    25
    Likes Received:
    17
    Trophy Points:
    3
    OK I tore the lot apart; removed everything one at a time and after each item I would zone in to my dungeon and back out. Then run around the town and back. The pets kept teleporting. Now it is a bare lot and the pets still teleport to the property to the East. It appears that while the Hay Drying Rack was not causing the underlining issue it was causing the pets to jump off the lot if I moved it around.

    It would seem the lot itself is bugged in some way. Can you please pass this along to the Devs so they can come take a look?
     
    Anpu and Alley Oop like this.
  7. that_shawn_guy

    that_shawn_guy Bug Hunter

    Messages:
    1,185
    Likes Received:
    3,161
    Trophy Points:
    125
    Location:
    earth... mostly
    Any town deco nearby? Like teleporters, etc?
     
    Anpu likes this.
  8. Sayge Raine

    Sayge Raine Bug Hunter

    Messages:
    25
    Likes Received:
    17
    Trophy Points:
    3
    No. This is Taenby Landing an NPC town.
     
    Anpu likes this.
  9. Ravalox

    Ravalox Dev At Large Moderator SOTA Developer

    Messages:
    1,182
    Likes Received:
    2,405
    Trophy Points:
    125
    Gender:
    Male
    Location:
    Austin, TX
    @Aksarben I replied to your Discord message. Summary: I suggest testing on QA as you will need to remove items from the Town lot to identify what is *really* causing the issues ... (based on my initial testing)
     
  10. Sayge Raine

    Sayge Raine Bug Hunter

    Messages:
    25
    Likes Received:
    17
    Trophy Points:
    3
    We think we have figured it out. Any pet (we tested Pallas Cat, White Rabbit with Black Spots(vault ed), White Goose and Tiny Airship) placed anywhere in the Lord Founder Town Home or on the lot while that house is there will break the pets on the village lot. We tested this by removing all pets on the Town lot and then placing them one at a time back down. We then would go in to the basement and back out to reset the zone. Then we would run a loop from the lot to the far end of the row lots past the central docks. This step alone broke the village lot about 10% of the time. Then we would zone out using the Blue Rose Isle boat and return to Taenby Landing. This step broke the village lot pets 100% of the time (a few times we had to port more than once but it would always break the village pets). At one point the Conversationalist went to my husbands lot 2 lots(Viking house on a village lot) and a road away. We also noticed that directly after coming out of the basement, resetting the zone, all the pets on both lots would have their names with the lot owners name over their heads. They would also have the normal pet drop down menu. After teleporting out to either the overworld or Blue Rose Isle when we came back 2 or 3 of the pets would no longer have a name over their head and instead had the normal Decoration drop down menus. Once all this testing was completed we then put the Lord Founder Town home in the Property Manager and placed Lord Benefactor Town Home; pets here did not break either lot so, it appears this is specific to the Lord Founder Town Home.
     
    Alley Oop, Anpu and Ravalox like this.
  11. Alley Oop

    Alley Oop Bug Hunter Bug Moderator

    Messages:
    12,492
    Likes Received:
    17,417
    Trophy Points:
    153
    verified on qa 1206. i placed an empty village lot and a town lot with lord founder home on adjacent lots in greenfall, with a llama and a giant squirrel on one and a llama and a giant bunny. it took SEVERAL sceneloads to get it to happen, but i did eventually find three pets on one lot and one on the other, with no deco other than the pets placed on either lot.

    [​IMG]

    Area: Greenfall (PRT_grassland_metropolis_01/Greenfall) Loc: (-98.036, 36, -218.506) DBG: UFJUX2dyYXNzbGFuZF9tZXRyb3BvbGlzXzAxfEdyZWVuZmFsbHwoLTk4LjAzNiwgMzYsIC0yMTguNTA2KXwoMCwgMC45MzUsIDAsIC0wLjM1NSl8LTEzNy4wMTMzfDMzLjQxMTAyfDE2LjE5OTk3
     
    Sayge Raine and Mikal Raine like this.
  12. Justyn

    Justyn Bug Hunter Bug Moderator

    Messages:
    826
    Likes Received:
    650
    Trophy Points:
    93
    Submitted: Issue 69309