Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Extremely low framerate on Mac AFTER tutorial

Discussion in 'Release 32 Feedback Forum' started by Rothgarr, Aug 25, 2016.

Thread Status:
Not open for further replies.
  1. Rothgarr

    Rothgarr Avatar

    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    Not sure if it's a bug or what, but when I am in the tutorial area (where you create your character and answer questions to determine character type) the game is buttery smooth on my 2 4 year old iMac. It also seems to let me run on most of the highest video settings.

    However, the moment I enter the world after the tutorial the game goes down to about 1 FPS. I tried entering the world as both a ranger and a mage so that I'd start out at different places and the result is the same. I also tried setting the video to the lowest settings -- it helps a little, but still close to only 1 FPS.

    The only time the frame rate goes back to normal is if I'm looking down at the ground.

    Anyone else on Mac have this problem? Any other info I can provide?
     
    Last edited: Aug 25, 2016
  2. Bluefire

    Bluefire Avatar

    Messages:
    530
    Likes Received:
    982
    Trophy Points:
    63
    Out of curiosity have you tried loading in using Single Player Online mode? I'm just curious if that helps at all.
     
  3. Gix

    Gix Avatar

    Messages:
    2,204
    Likes Received:
    4,017
    Trophy Points:
    153
    I don't have that issue, but then again I'm on a Mac Pro. Out of curiosity, do you have an iMac with a Retina Display?

    If you have a mid-2014 model, it was considered overall slower across the board compared to other models. If that's the case, I'd wait until Portalarium optimizes the game further.

    Look into your System Preferences and see if your dedicated video card is enabled.
     
  4. Rothgarr

    Rothgarr Avatar

    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    I'll try that when I get home tonight...
     
  5. Rothgarr

    Rothgarr Avatar

    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    I'm thinking my machine might be slower and older than I thought...

    It's a Late 2012 model, non-retina. 3.2 GHz i5, 8GB 1600 MHz DDR3, NVIDIA, GeForce GTX 675MX 1024 MB.

    I didn't see where in System Prefs I could check to see if the dedicated video card is enabled.

    I wonder if I won't be able to play after all on this thing.
     
  6. Gix

    Gix Avatar

    Messages:
    2,204
    Likes Received:
    4,017
    Trophy Points:
    153
    Automatic graphics switching
    [​IMG]
    With it enabled, it'll try to swap OUT of your dedicated video card to save power. Disabling it will guarantee that you're at least using it for SotA and, if performance doesn't improve, then at least you know it wasn't because you were using the integrated (shitty) intel chip.

    Granted, your desktop might not have that functionality.

    I also have a late 2011 Macbook Pro. While I admit that I haven't played SotA on it in a long time, I'd say that your computer should be powerful enough to play the game as I have. Your graphics card is known to actually perform better than the AMD Radeon HD 6770M I ran the game with.

    1 FPS is an anomaly and we'll try to help you out. What version of OS X are you running?
     
  7. Rothgarr

    Rothgarr Avatar

    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    Thanks for the help. That option doesn't appear for me in the Energy Saver control panel, I assume since it's not a laptop? (I'm on an iMac)

    My iMac is currently running 10.10.5 (Yosemite).
     
Thread Status:
Not open for further replies.