1. This forum is for bug reporting of current Player Test Environment (QA Server) issues ONLY.
    Be sure to follow the format below, it will help us out greatly in responding. If you do not, your report may not be entered into the system.

    Read BEFORE submitting your first bug: Reporting Bugsā€¦ QA 101 Document
    • Search for your bug in all likely categories before posting in order to avoid duplicate reports.
    • Be sure to provide details of what the issue is and how to re-produce it, but keep your bug report factual.
    • Reply to an existing thread if you have additional information for the reported bug.
      Do not use this forum for commentary, your post will be deleted and you may be moderated, suspended or banned if the activity continues.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    NOTE: Important information including your location and system specs are automatically put into your clipboard when using /devbug in the game (DO NOT add additional system specs unless requested). When starting your post, just use <CTRL>-V to insert the data and fill in the entries with no data.

    Please include Screenshots if possible. Images can be saved on our SotA Discord Server here

    If the clipboard does not work, use and fill in this Bug Report Template:
    1. Title:
    2. Reproducible?
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs: (RAM, CPU, GPU and Operating System only)

[Fixed 68142] when taking damage, characters keep repeating the last animation performed

Discussion in 'Combat, Skills & Magic' started by Rinaldi, Oct 27, 2020.

  1. Rinaldi

    Rinaldi Bug Hunter

    Messages:
    1,111
    Likes Received:
    2,992
    Trophy Points:
    113
    Gender:
    Male
    10/27/2020 20:50
    Title: when I take damage, my avatar keeps doing the last animation he performed
    Reproduction Rate: 100%
    Blocker? no
    Details: auto-attack was off. when i was attacked by a creature (and took damage), my avatar would keep doing the last animation i performed. Examples: I drank a potion and my avatar did the drink potion and break flask animation. Then an elemental attacked and i just stood there, and it hit me several times. Every time i took damage, i did the drink-potion-break-flask animation (even tho I was not activating any item or skill). Then i did a body slam into the elemental, and then stood there...and now every time to took damage, my avatar did the body slam animation (even tho I was not activating any item or skill). Then i cast a heal on myself and stood there, and every time i took damage, my avatar did the heal animation. I was able to reproduce this consistently.
    I think it's a global issue: This issue occurred in every zone I tested, including "the breach" and "Twins Foothills".
    Steps to Reproduce: see above.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz (8) System RAM: 32708
    GPU: NVIDIA GeForce GTX 1070 GPU RAM: 8088
    SotA.QA.Win.64.1092.Date.10.27.20
    Area: Mistrendur_TheBreach/New Scene
    Area Display Name: The Breach
    Loc: (-145.2, 60.2, -72.2)
    Debug: TWlzdHJlbmR1cl9UaGVCcmVhY2h8TmV3IFNjZW5lfCgtMTQ1LjE2NCwgNjAuMjM3LCAtNzIuMTYyKXwoMCwgLTAuNTYzLCAwLCAtMC44MjYpfC0yODExLjE3OXwxNy42NDI0OXw0LjMyMDAwMQ==
     
    Last edited: Oct 28, 2020
  2. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    2,855
    Likes Received:
    3,366
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    Repro'd this on QA1092 also
    Steps to Reproduce: Enter scene, go near where wolves are, but don't aggro them yet, drink a haste potion, stand still - wait for wolves to attack.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6800K CPU @ 3.40GHz (6) System RAM: 32679
    GPU: NVIDIA GeForce GTX 1070 GPU RAM: 8088
    SotA.QA.Win.64.1092.Date.10.27.20
    Area: RandomEncounter_Desert01/Wolf
    Area Display Name: Desert Encounter
    Loc: (69.3, 134.1, 69.2)
    Debug: UmFuZG9tRW5jb3VudGVyX0Rlc2VydDAxfFdvbGZ8KDY5LjI5OCwgMTM0LjA1OCwgNjkuMjA2KXwoMCwgLTAuMzM3LCAwLCAwLjk0Mil8LTc1MC4yNDh8MzYuMDE4Nzh8OS40ODA4MjE=
     
  3. Mimner

    Mimner Avatar

    Messages:
    147
    Likes Received:
    466
    Trophy Points:
    18
    I'm getting 100% movement speed reduction when getting hit by disabling shot from multiple npc archers.
     
  4. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    2,855
    Likes Received:
    3,366
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    @Mimner
    Can you please type /bug in game, and paste the info into the bug report here and fill in the details? Also, provide info on the specific mobs causing it /scene where it's occurring. Thanks.
     
  5. Mimner

    Mimner Avatar

    Messages:
    147
    Likes Received:
    466
    Trophy Points:
    18
    I observed it from elves in Tartarus and Satyrs in Ruined Keep.
     
  6. Mimner

    Mimner Avatar

    Messages:
    147
    Likes Received:
    466
    Trophy Points:
    18
    Okay, I have a 100% repo case for you.

    1) Get hit by disabling shot or root from npc (not player). I used spiders and elf archers in Savrenoc Stronghold.
    2) Cast ring of fire.
    3) The avatar then gets stuck in the rof animation which plays on a loop. This animation prevents movement.
    4) Eventually the animation stops playing. I've seen it loop for as long as 10s.
    5) During the animation loop, casting healing touch breaks the animation cycle and frees me up to move again immediately.
     
  7. Anpu

    Anpu Bug Hunter

    Messages:
    5,538
    Likes Received:
    6,176
    Trophy Points:
    153
    Location:
    Pacific Northwest
    Echondas and Mimner like this.
  8. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    2,855
    Likes Received:
    3,366
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    Gotcha - that bug is already in the queue for assignment of an issue # - I'll add this info to it.
     
    Last edited: Oct 29, 2020
    Anpu likes this.
  9. Ravalox

    Ravalox Dev At Large Moderator SOTA Developer

    Messages:
    1,074
    Likes Received:
    2,262
    Trophy Points:
    125
    Gender:
    Male
    Location:
    Austin, TX
    Issue# 68142 created.
     
  10. AoiBlue

    AoiBlue Bug Hunter

    Messages:
    408
    Likes Received:
    313
    Trophy Points:
    55
    Gender:
    Male
    11/02/2020 23:45
    Title: Magic Animations Repeated Under Certain Circumstances.
    Reproduction Rate: Uncertain.
    Blocker? no (cosmetic, but annoying)
    Details:Magic animations repeat if the spell survives an attack that would disrupt it.
    Steps to Reproduce: Attempt a charged low level magic spell attacking an animal that can disrupt your magic, such as a boar. Let it strike you while the magic spell is charging, and if the spell charge survives the animation will switch into the cast animation repeating.
    User Specs:
    OS: Linux 5.4 Ubuntu 20.04 64bit
    CPU: AMD Ryzen 5 1500X Quad-Core Processor (8) System RAM: 32111
    GPU: Radeon RX 5500 XT (NAVI14, DRM 3.40.0, 5.4.0-52-generic, LLVM 11.0.0) GPU RAM: 7961
    SotA.Linux.64.1301.Date.10.31.20
    Area: Mistrendur_Ulfheim_Classic
    Area Display Name: Ruins of Utheim
    Loc: (100.6, 19.3, -114.1)
    Debug: TWlzdHJlbmR1cl9VbGZoZWltX0NsYXNzaWN8fCgxMDAuNjUsIDE5LjI5NiwgLTExNC4xMTcpfCgwLCAwLjk2MywgMCwgLTAuMjY5KXwxNjUxLjYyNXwyOS4zMTU2MXwzLjUwOTI3Mg==
     
  11. Rinaldi

    Rinaldi Bug Hunter

    Messages:
    1,111
    Likes Received:
    2,992
    Trophy Points:
    113
    Gender:
    Male
    This issue appears to be fixed in patch 1305: SotA.Win.64.1305.Date.11.03.20
     
    Anpu and Alley Oop like this.