1. We have a QA initiative where we work with the community more closely than ever to get your bug reports into the hands of the developers. Please use this forum for LIVE Server bug reporting. Do follow the format below, because it will help us out greatly in responding. If you do not, it's possible your bug report will be misinterpreted, or worse, lost!

    Read BEFORE submitting your first bug: Reporting Bugsā€¦ QA 101 Document
    • Disable all Lua Add-Ons by using '/lua unload' in local chat or temporarily move all files/folders out of the SotA Lua folder then restart the game.
      Ensure the issue still occurs before submitting a bug; Support staff will not debug Add-On issues
    • Search for your bug before posting in order to avoid duplicate reports.
    • Only reply to an existing thread if you have additional information for the reported bug. ALL extraneous commentary will be deleted to avoid cluttering the reports.
    • Keep your bug report short and factual.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    Bug Report Template
    1. Title:
    2. Reproduction Rate:
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs:
    To get started, use /bug in-game (/devbug if on QA) to auto-create this template. It will even auto-fill some of the required information and open the browser for you. Then take the information that was just saved to your system's clipboard and paste it into a new QA forum post. Thank you bug hunters!
Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

FPS Drops by 10 when Shadows enabled, appears to switch from GPU to CPU

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by milspec, Jan 23, 2018.

Thread Status:
Not open for further replies.
  1. milspec

    milspec Avatar

    Messages:
    7
    Likes Received:
    10
    Trophy Points:
    3
    Hi,

    I am getting a -10 FPS drop (or more) when enabling shadows inside, for example in the Monastery in Highvale Outskirts. When I enable shadows I notice the utilization on my GPU drops and it increases on my CPU. When I turn shadows off, the load increases on my GPU and decreases on my CPU.

    CPU: Intel i5 7600k (Win 10 Pro - game exe set to Win 8 compatability)
    GPU: Nvidia GTX 980 (latest driver, v3.12.0.84)
    RAM: 16 GB
    Game installed to Samsung 840 EVO SSD
    Using website launcher, NOT using Steam

    With shadows off (all aprox averages over 10 seconds)
    FPS = 37
    GPU = 35%
    CPU = 55% (highest single game exe in process list)

    With shadows on (max for this example to exaggerate impact)
    FPS = 19
    GPU = 29%
    CPU = 64% (highest single game exe in process list)

    All video settings enabled for consistency while testing. Nvidia control panel options set to drive default. No custom Nvidia configuration for the game exe.

    I took some videos and screenshots. I didn't want to post here because of character name, user name, PC name etc all visible. But happy to share with the developers if you let me know how (Dropbox link via private email?).

    I took this as a sample because of the possible frame-rate improvements from 49 to 50, I wanted to see if I saw any difference.

    Happy to help diagnose however you like.

    - milspec

    1/23/2018 8:44 PM
    Title:
    Reproduction Rate:
    Blocker?
    Details:
    Steps to Reproduce:
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i5-7600 CPU @ 3.50GHz (4) System RAM: 16343
    GPU: NVIDIA GeForce GTX 980 GPU RAM: 4053
    SotA.EarlyAccess.LIVE.Win.64.716.Date.12.19.17
    Area: Novia_R6_Hills04_01
    Area Display Name: Highvale Outskirts
    Loc: (55.6, 172.4, -396.2)
    Debug: Tm92aWFfUjZfSGlsbHMwNF8wMXx8KDU1LjY0NywgMTcyLjM4NywgLTM5Ni4yMil8KDAsIC0wLjg3NiwgMCwgMC40ODMpfDIzNy43NDJ8MTB8NC44OTQyNjg=
     
    Last edited: Jan 23, 2018
Thread Status:
Not open for further replies.