Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Info needed] gotta get rid of this town and (to lesser extent) Overworld lag. :(

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Steevodeevo, Jun 10, 2018.

Thread Status:
Not open for further replies.
  1. Steevodeevo

    Steevodeevo Avatar

    Messages:
    1,431
    Likes Received:
    2,803
    Trophy Points:
    113
    @Chris and of course others. You are recognised as rock stars in your profession, so why do I stutter around mostly every town and on the Overworld map all the time?

    The game is clearly getting stronger and stronger to any right minded person, but there is an aggressive anti-game mob who look for every opportunity to criticise. I vehemently defend the game as I love it, but it drives me nuts that it lags and stutters like something I played on my old modem in 2005 in towns and on the o.w. map.

    Please see what you can do about this urgently before doing anything else. Any new player, especially non tech ones will simply assume a game that stutters like this is crap.

    Sorry to be blunt.
     
    Sorthious likes this.
  2. Rentier

    Rentier Avatar

    Messages:
    915
    Likes Received:
    1,303
    Trophy Points:
    105
    Location:
    Dragomir Mori
    today i had also already 2 disconnects due to "network congestions" -but my youtube or twitch never wavered...
     
    Sorthious and Steevodeevo like this.
  3. Anpu

    Anpu Bug Hunter

    Messages:
    6,477
    Likes Received:
    7,536
    Trophy Points:
    153
    Location:
    Pacific Northwest
    i believe stuttering is from too high GPU usage? I don’t think it is network related?
     
  4. Lexie

    Lexie Bear Queen Emeritus

    Messages:
    839
    Likes Received:
    2,902
    Trophy Points:
    93
    When reporting issues, it's best to not assume everyone is seeing it so we can identify issues more quickly. I'm not stuttering in game at all (and I played a lot, didn't leave my cave all weekend, having been sick!) The client was open for long periods of time. Jaesun is right: we need to find the cause. @Steevodeevo can you check through task manager please to see how your computer is managing CPU and memory when this happens?
    It would also be good to know if a full client restart resolves it.

    Also when reporting any technical issues we need the /bug information every time. Spec info at least gives us something to work with.
     
    Jaesun likes this.
  5. Feeyo

    Feeyo Avatar

    Messages:
    1,718
    Likes Received:
    2,524
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Yep the stuttering is driving me crazy also. I will try to do some monitoring these days.
     
  6. Steevodeevo

    Steevodeevo Avatar

    Messages:
    1,431
    Likes Received:
    2,803
    Trophy Points:
    113
    Sorry @Lexie :( I was a bit frustrated at the time when I posted that message. Just getting a bit tired of the stutter that happens to me, unlike yourself, in pretty much every town, and as I say, to a lesser extent on the world map.

    Here is my bug report (though not really a bug?) and some details of my Spec.

    6/11/2018 4:26 PM
    Title:Stutter in towns and on overworld map
    Reproduction Rate: 100% but varies to extent.
    Blocker? no
    Details: see above and spec details below
    Steps to Reproduce: enter towns or world map and run around
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz (8) System RAM: 16337
    GPU: NVIDIA GeForce GTX 760 (192-bit) GPU RAM: 1495
    SotA.Win.64.791.Date.06.06.18
    Area: POT_grassland_metropolis_01_template/Dawn's Keep
    Area Display Name: Dawn's Keep
    Loc: (110.0, 41.2, -49.0)
    Debug: UE9UX2dyYXNzbGFuZF9tZXRyb3BvbGlzXzAxX3RlbXBsYXRlfERhd24ncyBLZWVwfCgxMDkuOTgsIDQxLjE3NCwgLTQ4Ljk3OCl8KDAsIC0wLjkxNSwgMCwgMC40MDMpfC01NTcuNzg4M3w1Mi4yMzc5MXwzLjA2NTEzOA==

    Here is my graphics set up... I'm guessing here the instinctive reaction would be reduce settings and see what happens. I can (and will) try to determine if my stutter issues are graphics related (shadows, AA, etc) but to be honest I run equally or more demanding games than SOTA and I have 16 GIG of RAM:

    top of window -
    [​IMG]

    bottom of window-
    [​IMG]
     
  7. Anpu

    Anpu Bug Hunter

    Messages:
    6,477
    Likes Received:
    7,536
    Trophy Points:
    153
    Location:
    Pacific Northwest
    To see your GPU usage (in Windows) ALT/TAB from game, press CTRL ALT DELETE then some options are available, click on Task Manager. Then click on the Processes tab. Look at the Shroud of the Avatar app and you can see how much GPU usage it is using.

    If it’s at around 95% or higher, you are probably going to be stuttering a lot.
     
  8. Steevodeevo

    Steevodeevo Avatar

    Messages:
    1,431
    Likes Received:
    2,803
    Trophy Points:
    113
    yep, its running between 96-100%, more often towards 100%!

    extra info - I've just systematically turned low, then off things like cloth simulation, shadows, reflections and it makes no difference to my CPU loading into the 'red' upwards of 99%
     
    Last edited: Jun 11, 2018
    Sorthious, Feeyo and Jaesun like this.
  9. Feeyo

    Feeyo Avatar

    Messages:
    1,718
    Likes Received:
    2,524
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Yes, I have also tried playing with different ingame performance settings. It does not help at all.
    I even changed my AMD GPU card settings (AA, AF and other options) same effect. It did not make a difference.
     
    Sorthious likes this.
  10. Feeyo

    Feeyo Avatar

    Messages:
    1,718
    Likes Received:
    2,524
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    @Lexie When such a freeze/stutter happens GPU/FPS just drops like being on pause. I have made screenshot when it happens and you can see the graps just falling down.
    Also I have noticed one of the CPU cores always being a 100%, and when such a freeze happens. The main (mother) Process (the 100% one) jumps to another core ID. Maybe the devs can use affinity to stick process to a specific core, so that moving processes from core to core does not happen.
    As you can see on screenshot nr2, the spike again happened and the 100% usage process jumped from core x to core 0.

    Another point I would like to make, the message queue for the API data could also be a reason we are having stutters. I can imagen all clients online pushing out UDP API data creating a internal flood for some kind.

    Screenshot 2:
    [​IMG]


    Screenshot 1 GPU drop:
    [​IMG]
     
    Jaesun, Sorthious and Steevodeevo like this.
  11. Feeyo

    Feeyo Avatar

    Messages:
    1,718
    Likes Received:
    2,524
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
  12. Feeyo

    Feeyo Avatar

    Messages:
    1,718
    Likes Received:
    2,524
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Yes, I am almost a 100% sure it has to do with the outgoing/incoming messages with data.
    (IncomingMessages, Total=48, NumPlayers=1, SceneId=HiddenVale_Forest02_Tier5,Room=29bf8754-fe77-4cca-9682-be41eae455cc
    FPSMeter, fps=46.3, SceneId=HiddenVale_Forest02_Tier5, pos=(82.979, 33.933, -36.557), graphicsDeviceName=Radeon RX 580 Series (POLARIS10 / DRM 3.25.0 / 4.17.0-0.rc1.git1.1.fc29.x86_64, LLVM 6.0.0), graphicsMemorySize=8117, systemMemorySize=32088, processorType=Intel(R) Core(TM) i7-3960X CPU @ 3.30GHz, firstPersonCam=Fals
    , (OutgoingMessageQueue, Total=54,Master=True,SceneId=HiddenVale_Forest02_Tier5,timeScale=1.00,SetViewState:47,RaiseInstantiateEvent:1,SubscribeToView:1,SetRoomProperties:1,EnableUnreliableMessages:1,Ping:1,SetSaveLocation:1,SetInteractiveObjectStates:1,Room=29bf8754-fe77-4cca-9682-be41eae455cc))

    Every time I see this my game stutters.
     
  13. Lexie

    Lexie Bear Queen Emeritus

    Messages:
    839
    Likes Received:
    2,902
    Trophy Points:
    93
    It's all good. I can completely understand why you would be frustrated. I had some problems with my PC at home for a bit that was causing some Sota loading problems (in the last release) and I was cursing up a storm to myself. I will never take it personal :) It's just sometimes knowing about an issue isn't enough to help us get to the bottom of it, so I appreciate your extra efforts!

    In fact we have some really good info in this thread from you and others. I'm passing it along internally. Stay tuned.

     
Thread Status:
Not open for further replies.