1. Before posting any MODs, please contact us at support@portalarium.com to ensure your MOD is acceptable to the Terms of Service and EULA of the game. Portalarium is not responsible for use of MODs and possible adverse effects on your client or computer, and we may take action on accounts using MODs that are deemed illegal. Whether submitted here or elsewhere in the community, use MODs at your own risk!
    Dismiss Notice

Install SOTA QA Server on Ubuntu Linux 18.04

Discussion in 'Player Created Resources' started by Kaffien, Jun 16, 2018.

  1. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    Keep in mind this is NOT a script. You'll need to type in / copy and past the lines not commented
    out with a # sign.


    #Get SOTA QA Server running In Ubuntu Linux 18.04, standard ubuntu install with GNOME.
    #The hashtags / pounding signs signify comments. Everything else is a command to type.
    #In this tutorial, we are setting up SOTA QA server , this tutorial assumes a few things.
    #1. Your’re running Ubuntu 18.04
    #2. You’re using and AMD rx580 or similar generation. If Nvidia you’ll need to get the binaries from
    # NVIDIA’s website. If requested I will make another tutorial on that as well.

    #Download the QA version of the SOTA install client. In this case we’ll use the default 1.10.
    #Do NOT grab the deb file, do not use the 64bit version in the tar.gz file either.
    #Both cause the xsession / desktop ie Gnome in ubuntu’s case to close and restart.
    #So far the only patcher i’ve gotten to work is the 32 bit one, or using STEAM. If you want both the #QA and Live versions you’ll need to do one with the normal SOTA installer.

    #Begin tutorial

    #open up a terminal, I like using gnome-terminal
    press ALT+F2
    type gnome-terminal press enter.

    #Install the 32bit compat libraries copy and paste one long command.
    sudo apt-get install lib32ncurses5 lib32z1 libxcursor-dev:i386 libxrandr-dev:i386 libgl1-mesa-glx:i386 libgl1-mesa-dri:i386


    #Next, start off by looking for updates on basic install, then do the upgrades as required.
    #Second, install lynx just in case you lose your GUI (it happpens something)
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install lynx

    #Next we get the amd drivers for the RX580. This tutorial links the exact drivers for the rx580.
    #Below you’ll find a page with more drivers / different operating systems, simply substitute your
    #driver in the wget command.

    wget https://www2.ati.com/drivers/linux/ubuntu/18.04/amdgpu-pro-18.20-606296.tar.xz

    cd ~/Downloads
    tar xvf amdgpu-pro-18.20-606296.tar.xz
    cd amdgpu-pro-18.20-606296
    sudo ./amdgpu-install


    #Finish the install, once it is done you will need to restart your machine.


    #Log back in, open another terminal
    press ALT+F2
    gnome-terminal
    cd ~/Downloads
    wget
    https://d2sx9mrt4zumaq.cloudfront.net/Installers/shroud-of-the-avatar-launcher-qa_1.1.0.tar.gz
    tar xvf shroud-of-the-avatar-launcher-qa_1.1.0.tar.gz
    cd StandaloneLinuxUniversalPatcher
    ./Shroud\ of\ the\ Avatar\ -\ Launcher.x86
    #Install as normal, enjoy shroud of the avatar!


    #If you need some more info check the following pages.
    #Go to amd’s website and grab the right driver for your version.

    #https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-Release-Notes.aspx
    #Extra Instructions, READ THEM!
    #
    https://support.amd.com/en-us/kb-articles/Pages/Installation-Instructions-for-amdgpu-Graphics-Stacks.aspx
    #This is an AMD tutorial If requested I will do an NVIDIA one as well.
    #Have a great day and hopefully, enjoy SOTA!


    #End tutorial

    #If you lack a GUI, run lynx, a great text based browser. (we installed it earlier)
    #examples goes like this lynx www.shroudoftheavatar.com
    #Pressing G allows you to type in the address above. Once you found a link to download press D
    #then save as, press enter. Use Q to quit.
     
    Last edited: Jun 18, 2018
  2. Feeyo

    Feeyo Avatar

    Messages:
    431
    Likes Received:
    687
    Trophy Points:
    43
    Hi,
    Sorry for posting, but this post has a lot of wrong information.

    1) The .deb file is OK to use if you are on Debian/Ubuntu. You can install the .deb with you package manager.

    2) The 64bit client is perfectly fine to use, I did not experience any problems with this client.

    3) Why the amdgpu-pro prop. drivers? I really would hint you to use the open source amdgpu drivers, they perform better and do not have old xorg and kernel dependency problems.
    Note: For nVidia users I do hint to use the proprietary nvidia blob.

    4) I presume that you have a GNU/Linux Desktop to play SotA. So you can also just click on the sota launcher with your mouse to start?.

    5) Hint/Tip: Running Xorg or Wayland both work great. When running on Wayland you do not have any problems with vsync issues as those do not exists in Wayland and Wayland is a lot lighter then Xorg.
     
    Last edited: Jun 17, 2018
    Sorthious likes this.
  3. Sorthious

    Sorthious Avatar

    Messages:
    758
    Likes Received:
    923
    Trophy Points:
    93

    I used the Deb file without issue and am running the 64-bit client on 18.04. I have an RX480 and the AMD Proprietary drivers crashed my system. Besides, the stock drivers for Ubuntu are better for playing games anyway.
     
    Feeyo likes this.
  4. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    Two seperate systems, same issues with the 64 bit launcher. I cannot get it to load at all. The .Debi's 64 bit and crashes instantly on both systems.

    Perhaps it's something to do with an AMD cpu?
    Both systems use and. Ryzen 7 1700 in one and Threadripper 1950x in the other.

    I found better perf not using the the amdgpu-pro driver. Using the normal one (and drivers came with pro and regular) was far better. I will revise after using the stock driver from Ubuntu repos.

    Clicking on the binary for the 64 bit launcher gives me the same X crash. Takes me right back to the login screen.

    This happens on both the Nvidia 1070ti proprietary driver and the and rx580 drivers both pro and regular.

    I will try the amd ones that come with Ubuntu.
     
    Sorthious likes this.
  5. Sorthious

    Sorthious Avatar

    Messages:
    758
    Likes Received:
    923
    Trophy Points:
    93
    Yeah, I recently tried the AMD Pro drivers and they made my computer unbootable. I had to uninstall the drivers to get the computer to boot. I'm running an Intel CPU, so maybe there is an issue with the AMD CPU. There were issues in the game early on with, if I remember correctly, the AMD A8 processors, but that was resolved. Need to find someone else with your CPU(s) and see if you can replicate the issue.
     
    Feeyo likes this.
  6. Feeyo

    Feeyo Avatar

    Messages:
    431
    Likes Received:
    687
    Trophy Points:
    43
    I am not aware of on which xorg server ubuntu currently is, but the current version of xorg server is not supported with amd pro drivers. this is probably the reason why X is crashing.
     
    Sorthious likes this.
  7. Feeyo

    Feeyo Avatar

    Messages:
    431
    Likes Received:
    687
    Trophy Points:
    43
    I just checked the latest amd drivers and they seem to have removed being dependant on xorg and kernel version so it seems. I was not aware of this, sorry for giving incorrect feedback. In the past this was the case so I stand corrected :)

    Will do some testing tonight and see if I can reproduce the problems you have.
    If I find the error, I will update here.
     
    Sorthious likes this.
  8. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    Which are the best open source drivers to use for the RX580 ? How do i go about installing those instead of the amd's proprietary ones?

    Nm, just unintalled the proprietary ones. I will be re writing this tutorial.

    Using Xorg vs wayland didn't matter. Once i removed the drivers from AMD's website, the 64bit installer worked. I think it may have something to do with the proprietary drivers. This same issue was found with the NVIDIA drivers to.
     
    Last edited: Jun 17, 2018
    Sorthious likes this.
  9. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    I've also tried Wayland ... same issue. Also, what is with the random black flickering it's driving me nuts!
    It only happens on the system using the AMD video card.


    **edit haven't had time to test but this might have also been related to using non opensource drivers**

    Thanks for the input guys. If anyone else is using opensource drivers for the RX580 would you mind
    posting your average FPS on full 'best' settings in SOTA? I'd like to compare.
     
    Last edited: Jun 17, 2018
    Sorthious likes this.
  10. Feeyo

    Feeyo Avatar

    Messages:
    431
    Likes Received:
    687
    Trophy Points:
    43
    So the closed source drivers still are dependent on Xorg and kernel versions. They do not want to build/install against my system :(
     
    Sorthious likes this.
  11. Feeyo

    Feeyo Avatar

    Messages:
    431
    Likes Received:
    687
    Trophy Points:
    43
    Fully uninstall the amd drivers first, then install the ubuntu amdgpu opensource drivers:

    apt-get install xserver-xorg-video-amdgpu libdrm-amdgpu1


    What do you have configured in your Xorg configuration?

    This is my config for RX580:

    Code:
    cat /etc/X11/xorg.conf.d/20-gpu.conf
    Section "Device"
        Identifier    "AMD"
        Driver        "amdgpu"
        Option        "DRI"        "3"
        Option        "TearFree"    "true"
        Option "Accel" "true"
    EndSection
    
    I also recommend adding: mem_encrypt=off to your bootloader.
    edit: /etc/default/grub:
    Code:
    GRUB_CMDLINE_LINUX="mem_encrypt=off radeon.si_support=0 radeon.cik_support=0"
    Then rebuild you grub loader with grub2-mkconfig -o /boot/grub/grub.cfg
     
  12. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    Code:
    /usr/share/X11/xorg.conf.d$ ls
    10-amdgpu.conf  10-quirks.conf  10-radeon.conf  40-libinput.conf  70-wacom.conf
    
    Code:
    cat 10-amdgpu.conf 
    Section "OutputClass"
        Identifier "AMDgpu"
        MatchDriver "amdgpu"
        Driver "amdgpu"
    EndSection
    {/CODE]
    
    I couldn't find it stored anywhere else...  is there a command to find out for sure which config is being used?
     
  13. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    fun side node ... steam won't start anymore.

    If i install the proprietary ones again steam starts just fine. I used the same specs you mentioned. I installed the packages. hrrm.
     
    Last edited: Jun 17, 2018
  14. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    steams got some issues and the amdgpu from amd.com adds in a bunch of 386 libraries to make it less insecure about itself.
    While not ideal I'll be using the proprietary ones for now. input still welcome.
     
  15. Feeyo

    Feeyo Avatar

    Messages:
    431
    Likes Received:
    687
    Trophy Points:
    43
    I see you also have an 10-radeon.conf, this one should not be there. Only the amdgpu one.
    As you can not load both modules (driver: amdgpu, driver: radeon) on your system. This will give you problems. You need to blacklist the radeon module.
    Also when running the proprietary drivers be sure to double check if your kernel is not loading the opensource ones.
     
  16. Kaffien

    Kaffien Avatar

    Messages:
    397
    Likes Received:
    581
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Blue Rose Isle, Goldfield
    Yeah I already pulled the radeon and lsmod / grepped radeon it isn't loaded.
    All is good for now. Thanks.