Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Known]Mouse left click not functioning with login screen [Linux]

Discussion in 'Release 42 Bug Forum' started by greggreen, May 26, 2017.

Thread Status:
Not open for further replies.
  1. greggreen

    greggreen Avatar

    Messages:
    0
    Likes Received:
    1
    Trophy Points:
    2
    Reproduction Rate:
    Tried 5 times same result

    Blocker?
    Happened after latest update

    Details
    Launching the game from steam. When the Play screen opens, the cursor will not highlight the green gem. If I the mouse left click nothing happens. If I press enter I can get past that. At the construction screen, again I cannot press the the long bar button, if I press enter I can continue. At the Play Online / Options screen there is no way to interact so I cannot log in at all. A friend who is running on the LAN with windows is fine.

    User Specs:
    Linux MInt 18 Sarah 64bt
     
    Ao Soliwilos likes this.
  2. Ao Soliwilos

    Ao Soliwilos Avatar

    Messages:
    678
    Likes Received:
    983
    Trophy Points:
    93
    Gender:
    Male
    Location:
    Europe
    I have the same problem, but I am not playing through Steam. Tried two different window managers.

    Reproduction rate: 100%
    Blocker? Yes.
    Details: Just start the game either with the Launcher or the game client directly. The mouse cursor changes graphics to the Shroud arrow, but the game does not acknowledge the cursor or mouse button clicks.

    Linux 64bit
    Kernel version 4.11.2
    Nvidia driver 381.22
    Xorg-server 1.19.3
    Resolution: 2560x1440
     
  3. Alley Oop

    Alley Oop Bug Hunter Bug Moderator

    Messages:
    10,167
    Likes Received:
    15,772
    Trophy Points:
    153
    i've found that it IS working, just not in the right place. for instance, the activation area for the play button is about an inch below the play button. resizing the window forces it to recalculate correctly.
     
  4. Attenwood

    Attenwood Portalarian Emeritus

    Messages:
    6,911
    Likes Received:
    5,866
    Trophy Points:
    153
    Suspect related to the following listen in the posted Known Issues:
    "Playing on Fullscreen in desktop environments other than Ubuntu’s Unity (Gnome3, KDE, Cinnamon, etc.) may result in being unable to click on anything. If the client is started in windowed, then adjusted TO fullscreen, it may then work."
     
    Katrina Bekers likes this.
  5. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    345
    Likes Received:
    842
    Trophy Points:
    43
    A recent unity3d bug was introduced where if you are using a non-unity user interface (KDE, Gnome, Xfce, Cinnamon, etc) and start the game in full screen mode you may not be able to click on anything. This obviously causes problems preventing you from playing the game. If you are encountering this issue the current workaround is:
    • Edit ~/.config/unity3d/Portalarium/Shroud of the Avatar/prefs and change the game to not start in full screen mode:
    Code:
    <pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>
    • Open your client
    • Switch back to full screen Options --> Video --> Full Screen
    We apologize for any inconvenience this may cause and will be pushing a fix asap.
     
  6. greggreen

    greggreen Avatar

    Messages:
    0
    Likes Received:
    1
    Trophy Points:
    2
    Yup ... this fixed it for me, thank goodness!
     
  7. Ao Soliwilos

    Ao Soliwilos Avatar

    Messages:
    678
    Likes Received:
    983
    Trophy Points:
    93
    Gender:
    Male
    Location:
    Europe
    This worked for me as well. Thank you. :)
     
  8. Katrina Bekers

    Katrina Bekers Localization Team

    Messages:
    2,806
    Likes Received:
    7,859
    Trophy Points:
    165
    Location:
    Kópavogur, Iceland
    Same issue: using KDE in Kubuntu and playing in fullscreen (1920x1080 upscaled to 3840x2160).

    Same workaround helps: edit the prefs file, starting windowed then going fullscreen.

    But

    I

    Have

    To

    Do

    It

    Every

    Time

    I

    Want

    To

    Play

    ...Please kill me.
     
  9. Wintermute of CoF

    Wintermute of CoF Avatar

    Messages:
    1,379
    Likes Received:
    2,435
    Trophy Points:
    113
    Gender:
    Male
    Location:
    London, United Kingdom
    Try to remember to switch back to windowed mode before exiting the game :)

    I did try setting -screen-fullscreen 0 as a launch option in Steam which was successful in that it started the game in windowed mode, but I found it also reset the prefs file so I had to manually change all my other settings back to what I wanted.
     
    Katrina Bekers likes this.
  10. warxnox

    warxnox Avatar

    Messages:
    138
    Likes Received:
    275
    Trophy Points:
    18
    Gender:
    Male
    Location:
    France
    Same issue here, running on Xubuntu 16.04 LTS, have to reload manually all my settings. That's harsh for a comeback in SotA after a 1 year pause :)
     
  11. Wintermute of CoF

    Wintermute of CoF Avatar

    Messages:
    1,379
    Likes Received:
    2,435
    Trophy Points:
    113
    Gender:
    Male
    Location:
    London, United Kingdom
    I think it ought to be possible to edit the prefs file through scripting, something like this in the Steam command options (WARNING: NOT TESTED IN ANY WAY, BACK UP PREFS BEFORE TRYING):

    Code:
    sed -i -e 's|<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>|<pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>|g' ~/.config/unity3d/Portalarium/Shroud\ of\ the\ Avatar/prefs && %command%
    Edit: I assume the Unity issue is this one?
    Woot‽
     
    Last edited: Jun 8, 2017
    Alley Oop and Katrina Bekers like this.
  12. Katrina Bekers

    Katrina Bekers Localization Team

    Messages:
    2,806
    Likes Received:
    7,859
    Trophy Points:
    165
    Location:
    Kópavogur, Iceland
    AFAIK, this is not fixed in R43.
     
    Wintermute of CoF likes this.
  13. herbstjahr

    herbstjahr Avatar

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    why they dont fix the bug and push it further to the comunity ?
    I am really disappointed
     
  14. Wintermute of CoF

    Wintermute of CoF Avatar

    Messages:
    1,379
    Likes Received:
    2,435
    Trophy Points:
    113
    Gender:
    Male
    Location:
    London, United Kingdom
    Apparently Unity's first attempt to fix this in the engine didn't work. There is a new fix but we likely won't see it until R44.
     
    Katrina Bekers likes this.
  15. raistlinii

    raistlinii Avatar

    Messages:
    46
    Likes Received:
    66
    Trophy Points:
    8
    Worked for me, disappoint is the same too. Fully reinstalled OS, and saw same issue.
     
    Katrina Bekers likes this.
Thread Status:
Not open for further replies.