1. We have a QA initiative where we work with the community more closely than ever to get your bug reports into the hands of the developers. Please use this forum for LIVE Server bug reporting. Do follow the format below, because it will help us out greatly in responding. If you do not, it's possible your bug report will be misinterpreted, or worse, lost!

    Read BEFORE submitting your first bug: Reporting Bugsā€¦ QA 101 Document
    • Search for your bug before posting in order to avoid duplicate reports.
    • Only reply to an existing thread if you have additional information for the reported bug. ALL extraneous commentary will be deleted to avoid cluttering the reports.
    • Keep your bug report short and factual.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    Bug Report Template
    1. Title:
    2. Reproduction Rate:
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs:
    To get started, use /bug in-game (/devbug if on QA) to auto-create this template. It will even auto-fill some of the required information and open the browser for you. Then take the information that was just saved to your system's clipboard and paste it into a new QA forum post. Thank you bug hunters!
Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Known] Reshaping a book causes a lockup

Discussion in 'Items & Inventory' started by Hawkwind, Jun 9, 2018.

  1. Hawkwind

    Hawkwind Avatar

    Messages:
    69
    Likes Received:
    186
    Trophy Points:
    20
    Gender:
    Male
    Location:
    Rift's End
    6/9/2018 10:07 AM
    Title: Reshaping a book causes a lockup
    Reproduction Rate: Tried twice, locked up twice
    Blocker? Yes
    Details: Bought a blank book and a book pattern, wrote in the book, published it then tried to reshape it at the tailoring station (odd, but ok), progress meter goes and when it completes all thee components turn red in the window and the window freezes and cannot be closed or cleared in anyway other then shutting down SOTA and restarting.
    Steps to Reproduce: Buy a blank book and a book pattern, write in the book, publish it then try to reshape it.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz (8) System RAM: 16313
    GPU: NVIDIA GeForce GTX 970 GPU RAM: 4059
    SotA.Win.64.791.Date.06.06.18
    Area: BasementSceneMedievalRow_5Floor
    Area Display Name: Row Stone & Timber 5-Story Basement
    Loc: (36.5, -3.3, 107.5)
    Debug: QmFzZW1lbnRTY2VuZU1lZGlldmFsUm93XzVGbG9vcnx8KDM2LjUwNCwgLTMuMjk4LCAxMDcuNDg1KXwoMCwgLTAuMDE4LCAwLCAtMSl8LTgwLjc0OTE3fDcuMDI2OTYyfDMuMDUyNTU4
     
    Alioth likes this.
  2. Lexie

    Lexie Bear Queen

    Messages:
    839
    Likes Received:
    2,901
    Trophy Points:
    93
    I can repro. Great find! Thank you so much.
    Bug #: 59978
    Interesting, reshaping a blank book worked just fine for me.
    @Hawkwind
     
  3. Alioth

    Alioth Avatar

    Messages:
    210
    Likes Received:
    525
    Trophy Points:
    18
    6/14/2018 9:14 PM
    Title:
    Reproduction Rate: tried once - It destroyed my book and pattern so did not try again : (
    Blocker?
    Details: Published a written book with [bb] code in it (looked fine in game unpatterned, then tried to reshape with Ranged pattern. Locked up. Had to force quit SOTA, wouldnt let me <esc> to menu, and /stuck didn't work.
    Steps to Reproduce: as above
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz (4) System RAM: 8052
    GPU: NVIDIA GeForce GTX 1080 GPU RAM: 8086
    SotA.Win.64.791.Date.06.06.18
    Area: POT_alpine_metropolis_01_template/Wizards Rest
    Area Display Name: Wizards Rest
    Loc: (-252.7, 66.5, 356.8)
    Debug: UE9UX2FscGluZV9tZXRyb3BvbGlzXzAxX3RlbXBsYXRlfFdpemFyZHMgUmVzdHwoLTI1Mi43NDQsIDY2LjQ3NywgMzU2Ljc3Myl8KDAsIC0wLjA4NywgMCwgMC45OTYpfDM0NS41MjJ8MzAuNjUxMjV8My4wODE4MTE=

    [​IMG]
     
    Last edited: Jun 14, 2018