Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Known] Rewards interface: all items always show green (new)

Discussion in 'User Interface (Including Launcher)' started by Echondas, Feb 23, 2019.

  1. Echondas

    Echondas Bug Brigade – Bug Hunter

    Messages:
    1,997
    Likes Received:
    2,592
    Trophy Points:
    125
    Gender:
    Male
    Location:
    NY
    02/23/2019 15:08
    Title: Rewards interface - all items / old items show as green (new)
    Reproduction Rate:1/1
    Blocker? No
    Details: in the Rewards UI - all my existing items show as green - which usually indicates an item is 'new'
    Steps to Reproduce: Open rewards interface with existing items in it.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6800K CPU @ 3.40GHz (12) System RAM: 32678
    GPU: NVIDIA GeForce GTX 1070 GPU RAM: 8088
    SotA.QA.Win.64.807.Date.02.22.19
    Area: Novia_R9_City_Northwood
    Area Display Name: Northwood
    Loc: (1.4, 43.5, -194.4)
    Debug: Tm92aWFfUjlfQ2l0eV9Ob3J0aHdvb2R8fCgxLjM5NSwgNDMuNDY0LCAtMTk0LjQxNil8KDAsIDAuMDQ2LCAwLCAtMC45OTkpfDM1NS4wNDE0fDMxLjMzODI0fDQuNDU3OTA3

    [​IMG]

    [​IMG]
     
    Jaesun and Alley Oop like this.
  2. Lord Subtleton

    Lord Subtleton SotA Dev

    Messages:
    993
    Likes Received:
    1,310
    Trophy Points:
    93
    Thanks for the post. Based on your description, it sounds like the UI is working as designed. The first time you open the rewards window, everything will be new. Subsequent times that you open the rewards UI, only newly purchases / rewards will be marked green. Also, the rewards icon at the top right of the screen will have a special badge that indicates when there are new items in your rewards. If this is not working as I detailed, please re-post with more details.
     
  3. Alley Oop

    Alley Oop Bug Brigade – Bug Hunter

    Messages:
    9,261
    Likes Received:
    14,875
    Trophy Points:
    153
    this is the bit that's not working. i had noticed it myself yesterday but saw echondas had reported it. subsequent opening within the same scene still green, scene change check again still green, quit and make a new session still green... just checked again before posting this.
     
    Echondas and Jaesun like this.
  4. Lord Subtleton

    Lord Subtleton SotA Dev

    Messages:
    993
    Likes Received:
    1,310
    Trophy Points:
    93
    Oh. Verified the bug. The screen shots were misleading. I'll put a note in the bug report to avoid there being a delay in resolution due to the screenshot. The bug is: Items almost always show up as green. The only time items are not green is if you make a purchase while the client is running.

    #Issue #64001
     
    Last edited: Feb 24, 2019
    Echondas, Alley Oop and Jaesun like this.
  5. Alley Oop

    Alley Oop Bug Brigade – Bug Hunter

    Messages:
    9,261
    Likes Received:
    14,875
    Trophy Points:
    153
    (the screenshots were one showing them green on qa and one showing them white on live to demonstrate that they had already been present, i think. watch for the yellow qa banner)
     
    Echondas and Lord Subtleton like this.
  6. Echondas

    Echondas Bug Brigade – Bug Hunter

    Messages:
    1,997
    Likes Received:
    2,592
    Trophy Points:
    125
    Gender:
    Male
    Location:
    NY
    Bingo :)
    (sorry I will be more clear next time!)