Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Linux Performance

Discussion in 'Release 61 Feedback' started by VAX-11/780, Dec 29, 2018.

Thread Status:
Not open for further replies.
  1. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    Overall the game runs really well compared to its Windows counterpart. There's just these 1 second mini-freezes that seem to happen fairly regularly, especially when quickly looking around. This has been drastically improved (from my perspective) since I first started playing, but it's really the only thing that kind of keeps me from vegetating in SotA these days. I hope this is something that gets ironed out completely in the near future. It's very much playable in its current state, it's just more of an annoyance than anything else, to be honest. Anyone else?

    Oh, while I'm on the subject, I'll hijack my own thread and bring up a cosmetic respec. Is this even a thing? They've added new hairdos since I made my character and I'd like to change to one of them.
     
  2. Alley Oop

    Alley Oop Bug Hunter Bug Moderator

    Messages:
    10,695
    Likes Received:
    16,069
    Trophy Points:
    153
    there are "new you" salons in central brit and ardoris. 5 crowns in advance, even if you decide not to change anything. better to make a new char offline or in an extra slot to preview the possibilities first.
     
    Elwyn and Three Eighty-Six like this.
  3. Barugon

    Barugon Avatar

    Messages:
    13,340
    Likes Received:
    20,821
    Trophy Points:
    153
    Gender:
    Male
    I only get the mini-freezes now while a scene is loading. Once it's fully loaded, it's pretty smooth. I expect that when Vulkan is fully implemented and available in Unity then this will no longer be an issue.

    FYI, Vulkan will allow them to load assets and push them to the GPU on a separate thread without interrupting the rendering process.
     
    Last edited: Dec 30, 2018
  4. Feeyo

    Feeyo Avatar

    Messages:
    1,718
    Likes Received:
    2,522
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    The mini freezes are object being loaded/rendered. I also only have them when just entering a scene. But never when some time in a scene.
    If you could let me know your Box setup: GPU + GPU driver, kernel version, distro of choice I maybe could help you out tweaking for faster performance.
     
    Three Eighty-Six likes this.
  5. Anpu

    Anpu Bug Hunter

    Messages:
    5,084
    Likes Received:
    5,642
    Trophy Points:
    153
    Location:
    Pacific Northwest
    Are you getting the occasional network icon that shows up? And then the game freezes for a second?
     
    Three Eighty-Six and Feeyo like this.
  6. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    Thank you! I didn't know that. I guess I have to travel to these cities and start searching soon!
     
  7. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    That sounds like the culprit, if I were to take a totally uneducated guess.
     
  8. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    Really? Thanks! I'm open to any suggestions!

    Lubuntu 18.04 (nearly clean install, 4.15.0-43-generic #46-Ubuntu SMP)
    MSI B85M-E45
    Intel i7-4790K @ 4.2GHz (Corsair water-cooled)
    G.Skill 16GB DDR3 RAM @ 1600MHz
    EVGA NVIDIA GTX 970 w/ 4GB RAM (390.xx proprietary drivers)
    Corsair Force-LE 960GB SSD (OS and SotA are on this drive)
    Western Digital Caviar WD40EZRZ-00G 4TB HDD
    Corsair RM750i PSU
     
  9. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    I am not getting that. Just getting bashed during scene loading for the most part.
     
    Jaesun likes this.
  10. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    Okay, so this is kind of weird... I just added a command that is run at login which forces my Nvidia card into performance (no power saving) mode. At the same time, there was also a patch for SotA. I'm not sure which did it, but I suddenly have 90% less noticeable stutter and it runs great. I wonder how this happened?
     
    Barugon likes this.
  11. Barugon

    Barugon Avatar

    Messages:
    13,340
    Likes Received:
    20,821
    Trophy Points:
    153
    Gender:
    Male
    If you use a processor that supports SMT/hyperthreading, it's beneficial to turn that off in the BIOS settings.
     
    Three Eighty-Six likes this.
  12. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    I like your signature quote.
     
    Barugon likes this.
  13. Black Tortoise

    Black Tortoise Avatar

    Messages:
    1,961
    Likes Received:
    3,656
    Trophy Points:
    125
    Gender:
    Male
    Location:
    Storm's Reach

    I think we need a "SoTA on Linux" forum :)
     
    Feeyo likes this.
  14. Alley Oop

    Alley Oop Bug Hunter Bug Moderator

    Messages:
    10,695
    Likes Received:
    16,069
    Trophy Points:
    153
    we had a discussion thread in the inbox started by @WrathPhoenix, but it's not been used in a while and probably needs new people invited
     
    Feeyo likes this.
  15. VAX-11/780

    VAX-11/780 Avatar

    Messages:
    162
    Likes Received:
    331
    Trophy Points:
    30
    Location:
    Pensacola, Florida, Earth, Dimension C-137
    Okay, so I solved the mini-freezes the other day. For me, it was the NVIDIA drivers defaulting the card into Auto or Power Saving mode. It needs to go into Performance mode. This is most easily accomplished by adding the following command into whatever system you're using to fire stuff up upon login/boot:

    @nvidia-settings -a GPUPowerMizerMode=1
     
    Jaesun likes this.
Thread Status:
Not open for further replies.