Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Mac version still crashes/freezes on entering Owl's Head

Discussion in 'Release 13 Feedback' started by Zauberfalke, Jan 18, 2015.

Thread Status:
Not open for further replies.
  1. Michael Jung

    Michael Jung Avatar

    Messages:
    20
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Mainz
    Anybody else has this problem ?
    Cannot play on Mac since R13, no update resolved it.

    Quite a bit frustrating ...
     
  2. Morkul

    Morkul Avatar

    Messages:
    620
    Likes Received:
    602
    Trophy Points:
    105
    Gender:
    Male
    Location:
    Gothenburg
    Just no long loading times? I can get way over one minute loading time when entering Owl and its the same in Linux, PC or Mac. Even though I prefer to play on Linux I haven't have any real problem with the mac version.
     
  3. Michael Jung

    Michael Jung Avatar

    Messages:
    20
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Mainz
    I waited for more than 5 min, still nothing. Before R13 I had about a min to wait if more ppl online.
     
  4. Tobias Crassus

    Tobias Crassus Avatar

    Messages:
    13
    Likes Received:
    17
    Trophy Points:
    3
    Ah, a fellow mac user, I have been wondering about the mac version compared to the windows one, as I've been having quite some performance issues really.

    I am running a:

    OSX Yosemite
    3.4 Ghz I7
    8gb DDR3
    AMD Radeon HD 6970M 2gb

    Im not claiming its the best machine ever, but I run games like The elder scrolls online in pretty high graphics and a few other games to without any sweat at all,

    But with this game even when running on the simplist graphic settings without any of the other things turned on, my Imac seems to be struggling and the fans go at top speed.

    I have the same issue with Owlshead to, but presume thats mainly due to player content and housing, but still I just find it concerning that my system can usually handle top settings on a variety of good games, but this one can struggle with the lowest settings?
     
    Tahru likes this.
  5. Tahru

    Tahru Avatar

    Messages:
    4,441
    Likes Received:
    11,420
    Trophy Points:
    165
    Gender:
    Male
    Location:
    Dragomir Mori
    Welcome Ikabard! Sorry you are having troubles there. R14 might be better, also you might try running with the Fastest video setting.
     
  6. Tobias Crassus

    Tobias Crassus Avatar

    Messages:
    13
    Likes Received:
    17
    Trophy Points:
    3
    Thank you!

    And sorry I thought from the top of my head that the "Simplest" was the lowest one, but I am infact running it from the "Fastest" version, with all the ambient and lens effect etc turned off, so do find it strange!

    Im hoping R14 perhaps makes performance a bit better, as its quite the struggle at times unless im in some areas that are more simplistic like combat areas outside of towns, but towns really kill the performance, but not to worry, just thought id mention it incase there was something that maybe code wise caused the Mac client to be overworking itself for no reason!
     
    Tahru likes this.
Thread Status:
Not open for further replies.