Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Not a bug] Rewards: Missing visual indicator

Discussion in 'User Interface (Including Launcher)' started by Echondas, Feb 23, 2019.

  1. Echondas

    Echondas Bug Brigade – Bug Hunter

    Messages:
    1,995
    Likes Received:
    2,592
    Trophy Points:
    125
    Gender:
    Male
    Location:
    NY
    02/24/2019 00:30
    Title: Rewards: Missing visual indicator
    Reproduction Rate: 100%
    Blocker? No
    Details: Release notes (draft) mention a visual indicator when rewards are delivered - however I have not seen one yet.
    Steps to Reproduce: As a test, I bought $8 of COTOs from the add-on store -- they were delivered properly to QA with 900 COTOs - but there was no visual indicator that I could tell? As another test after logging into QA today and getting the login rewards - I checked the UI area and didn't see anything obvious - but I checked the rewards and the COTOs were there.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6800K CPU @ 3.40GHz (12) System RAM: 32678
    GPU: NVIDIA GeForce GTX 1070 GPU RAM: 8088
    SotA.QA.Win.64.807.Date.02.22.19
    Area: Novia
    Area Display Name: Novia
    Loc: (172.1, 13.8, 338.0)
    Debug: Tm92aWF8fCgxNzIuMTEyLCAxMy44NCwgMzM4KXwoMC4wMDIsIC0wLjg0NiwgLTAuMDA4LCAtMC41MzMpfDE0My4zNDE2fDQ4LjQ0NDEyfDQw

    [​IMG]
     
  2. Lord Subtleton

    Lord Subtleton SotA Dev

    Messages:
    993
    Likes Received:
    1,310
    Trophy Points:
    93
    Thanks for the post. Based on your description, it sounds like the UI is working as designed. The first time you open the rewards window, everything will be new. Subsequent times that you open the rewards UI, only newly purchases / rewards will be marked green. Also, the rewards icon at the top right of the screen will have a special badge that indicates when there are new items in your rewards. If this is not working as I detailed, please re-post with more details.
     
    Jaesun likes this.
  3. Echondas

    Echondas Bug Brigade – Bug Hunter

    Messages:
    1,995
    Likes Received:
    2,592
    Trophy Points:
    125
    Gender:
    Male
    Location:
    NY
    The badge not showing up was what I was thinking of (the release notes didn't mention specifically what so I didn't know what to look for) -- I just tested again on QA using a Meretz Potion claim -- and the badge DID show up this time.

    Perhaps I had the rewards interface open the last time or something else was at play - I'll re-post if I notice anything again.