Performance ?

Discussion in 'Hardware, Software, Tech' started by Kyosa, Oct 10, 2019.

  1. Kyosa

    Kyosa Avatar

    Messages:
    59
    Likes Received:
    42
    Trophy Points:
    8
    Hi,

    I am using a Alienware Threadripper PC, 16Gb ram , ssd, Nvidia 2080ti.
    2 Monitors one is for the game fullscreen
    My ingame video settings are costum and i disabled/reduced everything.
    I always use the latest graphic drivers.

    But still, for example in UT with a group and a lot of fire circles in front of me
    the FPS goes down to 13 some times.

    Are the any tips i dont know ?
     
    Last edited: Oct 10, 2019
  2. Xee

    Xee Avatar

    Messages:
    1,165
    Likes Received:
    1,636
    Trophy Points:
    113
    by chance in UT is someone using the AOE Ice spell? I found that using the AOE ice spell seems to do something with the fps, the more its cast the slower things start to get until it reaches a point where I can move and have to exit and restart the game.
     
    StarLord likes this.
  3. StarLord

    StarLord Avatar

    Messages:
    459
    Likes Received:
    796
    Trophy Points:
    55
    Gender:
    Male
    this is sometimes bringing my FPS down to <1. When viewing away from the spells animation I get normal 20-40 FPS, back to the animation again <1.
    Seems to be independent of graphic settings.
    Only solution is to relog :-(
     
  4. Kyosa

    Kyosa Avatar

    Messages:
    59
    Likes Received:
    42
    Trophy Points:
    8
    Yeah true
     
  5. Xee

    Xee Avatar

    Messages:
    1,165
    Likes Received:
    1,636
    Trophy Points:
    113
    I run pretty much max, fire does not seem to cause me issues just the ice from what I can tell. I don't see it often when I am soloing , but when in group it seems to happen more frequently. could be other peoples ice maybe that is the trigger or just the extra ice going on. this is on current nvidia driver on a 2060GTX 6gb version.

    I put a bug in for this and Chris mentioned he is looking into this on his stream today :)
     
    StarLord, Aldo and Violette Dyonisys like this.
  6. StarLord

    StarLord Avatar

    Messages:
    459
    Likes Received:
    796
    Trophy Points:
    55
    Gender:
    Male
    Note: I had created a bug report on Sep 6th: Issue #65642
     
    CrandalltheFoole likes this.
  7. Anpu

    Anpu Avatar

    Messages:
    3,489
    Likes Received:
    3,881
    Trophy Points:
    153
    Chris is aware of the ice field issue. Unfortunately, it doesn’t effect everyone, so that makes it more difficult to figure out the cause. It’s more than likely a driver issue. On Chris’ computer he has that 20xx video card, but was using older drivers and he could not get the ice field problem to happen on his computer. He was discussing that in a previous livestream a few days ago. Just FYI.
     
  8. StarLord

    StarLord Avatar

    Messages:
    459
    Likes Received:
    796
    Trophy Points:
    55
    Gender:
    Male
    @Chris

    Adding my specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i9-9960X CPU @ 3.10GHz (32) System RAM: 65227
    GPU: NVIDIA GeForce RTX 2080 Ti GPU RAM: 11048
    Playing in windowed mode @3834 x 1433, 60 Hz
    NVidia driver 8.1.940.0
    Using the start option: "-force-d3d11-no-singlethreaded"

    Note: SoTa might need more memory when the bug occurs. Usually I see it @9 GB or so.
    With the bug it usually needs 11 GB (but still lots of memory is free)
     
  9. Barugon

    Barugon Avatar

    Messages:
    11,948
    Likes Received:
    18,967
    Trophy Points:
    153
    Gender:
    Male
    Did you try without this?
     
    Jaesun likes this.
  10. StarLord

    StarLord Avatar

    Messages:
    459
    Likes Received:
    796
    Trophy Points:
    55
    Gender:
    Male
    Had only added it because of the lag, but did not really help
     
    Barugon likes this.
  11. Kaffien

    Kaffien Avatar

    Messages:
    533
    Likes Received:
    812
    Trophy Points:
    75
    Gender:
    Male
    Location:
    Blue Rose Isle, Crafters Town, Black Rock Cove
    Do you get the same issues playing with just the laptop screen?
    Have you attempted to disable the peripheral lighting?

    Fire up your task manager (you may need to click more details)
    and check out the performance tab. Is anything maxing out?

    Lastly make sure your laptop's power profile is set to "high performance" instead of "balanced"
    make sure to switch it back if you ever use the laptop without the power bar.
     
  12. StarLord

    StarLord Avatar

    Messages:
    459
    Likes Received:
    796
    Trophy Points:
    55
    Gender:
    Male
    Playing on a desktop. Who wants to play on a laptop having a way more powerful desktop + 32" 4K monitor.
    Whats peripheral lighting? If related to a keyboard or mouse lighting, then I am not using it.
    Have not seen anything strange. With high FPS the GPU is under load, but with the bug the load is quite low.
    CPU usage and RAM usage is also low (in line with the powerful desktop)

    Note: the issue is random with low occurrence. Does not happen in solo play. And did not happen the last 3 days with multi (but did not have lots of ice fields...)
     
  13. StarLord

    StarLord Avatar

    Messages:
    459
    Likes Received:
    796
    Trophy Points:
    55
    Gender:
    Male
    @Chris
    Update: still happening every few hours. Mostly in UT with several players and AOE spells.
    But did also happen in solo play with no AOE (but in open mode)
    Framerate is dropping to ~1 FPS, mouse actions pretty much blocked, only keyboard commands possible.
    Only way to fix is to relog.
    Memory consumption was still < 10GB (no problem with my PC), no extensive GPU or CPU usage.
     
  14. Xee

    Xee Avatar

    Messages:
    1,165
    Likes Received:
    1,636
    Trophy Points:
    113
    I am still seeing that issue where after visiting some dungeons and porting back to Silverdale Market I get slow down when facing some directions where opposite of the slow is normal speed. Still not sure what causes that. same issue a relog fixes. I still think its texture related.
     
  15. StarLord

    StarLord Avatar

    Messages:
    459
    Likes Received:
    796
    Trophy Points:
    55
    Gender:
    Male
    Same for me in UT. Opposite of "action" I get high FPS, turning to the action I cant play.
    Not related to graphics quality settings. I have a high end machine and play in ~ 3800 x 1400 windowed.
     
  16. AoiBlue

    AoiBlue Avatar

    Messages:
    148
    Likes Received:
    104
    Trophy Points:
    30
    Gender:
    Male
    Like I said, it's I/O bottleneck and memory speed bottleneck.

    There are a list of things you can do to reduce this usage in the settings. Do them one by one to see what helps.

    First:
    Reduce the LODs. This will reduce GPU Memory bandwidth by reducing the amount of stuff that needs to be loaded.

    Second:
    Turn off cloth physics. This will reduce interaction between the CPU and the GPU.

    Third:
    Turn off peripheral lighting. This turns of lighting functions highlighting keys on LED keyboards. Seriously, it's unneeded, and the library for it is broken, causing large amounts of lag.

    Fourth:
    Don't leave your inventory window open. The Inventory window in particular is a lag generator, as it has to be rebuilt every time you get a new item. Seriously, keep it closed unless you are using it.
     
    Numa likes this.
  17. AoiBlue

    AoiBlue Avatar

    Messages:
    148
    Likes Received:
    104
    Trophy Points:
    30
    Gender:
    Male
    As a note, anything addition to this is largely things Portalium needs to do.
    It's not entirely their fault. Things that would run perfectly optimized on other game engines don't on the Unity3D game engine. These are largely compiler issues and issues with the memory management system, as well as core design issues of lacking features to prevent stutter and hitches.

    As of what performance you can expect:
    30-35fps excluding explicitly "broken" towns like Aria, and stutter from loading lots, both of which you can expect frames in the intolerable 25fps range for short periods of time.
    35-45fps for standard adventure level gameplay, not counting

    This is not counting server-side hitches, which are well beyond your control.
    This will result in a pause of gameply little over a half second, and what will seem like an eternity.