1. This forum is for bug reporting of current Player Test Environment (QA Server) issues ONLY.
    Be sure to follow the format below, it will help us out greatly in responding. If you do not, your report may not be entered into the system.

    Read BEFORE submitting your first bug: Reporting Bugsā€¦ QA 101 Document
    • Search for your bug in all likely categories before posting in order to avoid duplicate reports.
    • Be sure to provide details of what the issue is and how to re-produce it, but keep your bug report factual.
    • Only report oneissue per thread, additional issues may be ignored.
    • Do not add, include or modify the thread moderator tags in the title of the thread. (indicators in the [])
    • Reply to an existing thread if you have additional information for the reported bug.
      Do not use this forum for commentary, your post will be deleted and you may be moderated, suspended or banned if the activity continues.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    NOTE: Important information including your location and system specs are automatically put into your clipboard when using /devbug in the game (DO NOT add additional system specs unless requested). When starting your post, just use <CTRL>-V to insert the data and fill in the entries with no data.

    Please include Screenshots if possible. Images can be saved on our SotA Discord Server here

    If the clipboard does not work, use and fill in this Bug Report Template:
    1. Title:
    2. Reproducible?
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs: (RAM, CPU, GPU and Operating System only)

Previously placed deco pet on Town lot bugged after picking up & then re-placing

Discussion in 'Player Owned Town & Player Housing' started by Echondas, Dec 14, 2020.

  1. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    3,536
    Likes Received:
    3,834
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    12/14/2020 16:26
    Title: Previously placed deco pet on Town lot bugged after picking up & then re-placing
    Reproduction Rate: 100%
    Blocker? No
    Details: On my taxed Town lot, I picked up my wedgie cat deco pet and then put it back down. The nameplate is missing, and it cannot be targeted using single-click. The right-click menu is also missing 'dance' and 'teleport' functions. After doing this, any new deco pets placed on the same lot also exhibit this behavior. When placing the same pet on another lot in the same scene, the issue persists. Note: this is not related to the Unity upgrade, since the bug exists on Live also.
    Steps to Reproduce: Enter a freshly created scene with a deco pet that was previously placed. Pick up a previously placed deco pet using the right click interface. Put the pet back on the same lot. If a NEW pet is put on the lot, after loading into the scene, this doesn't happen, and everything works as expected. The pet must already exist prior to entering the scene.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz (4) System RAM: 8073
    GPU: Intel(R) HD Graphics 520 GPU RAM: 2146
    SotA.QA.Win.64.1111.Date.12.11.20
    Area: Novia_R9_City_Northwood
    Area Display Name: Northwood
    Loc: (157.0, 39.0, -310.6)
    Debug: Tm92aWFfUjlfQ2l0eV9Ob3J0aHdvb2R8fCgxNTcuMDQ2LCAzOSwgLTMxMC41OTEpfCgwLCAwLjI0NywgMCwgLTAuOTY5KXw0MzUuMzgwMnw1OS4wMDA2OXwxNC4wMjc0Ng==

    [​IMG]
     
    Last edited: Dec 14, 2020
  2. Echondas

    Echondas Bug Hunter Bug Moderator

    Messages:
    3,536
    Likes Received:
    3,834
    Trophy Points:
    165
    Gender:
    Male
    Location:
    NY
    This bug seems specific to Town lots and larger. As a test, on QA, I upgraded a deed to City Lot Deed, and claimed a lot. I then bought deco pets from the Crown shop and placed them on the lot. All except 2 of them were missing name plates and had the limited set of right-click menu options pictured in screen shot above.
     
  3. Anpu

    Anpu Bug Hunter

    Messages:
    6,442
    Likes Received:
    7,514
    Trophy Points:
    153
    Location:
    Pacific Northwest
    Yeah this might be size related? I picked up my Squirrel pet. Place in inventory, then place back down. No issues in a Village size lot (or just this specific pet):

    [​IMG]
    [​IMG]

    All options were available to me when picking up and replacing the same pet.