Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Request for QA Mac testers

Discussion in 'Release 49 QA Feedback Forum' started by Undone, Dec 5, 2017.

Thread Status:
Not open for further replies.
  1. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    346
    Likes Received:
    848
    Trophy Points:
    43
    Let's see if we can force your client to do the resolution we want. The first thing we can try is setting it via command line; the downside is that the settings might not work because the game reads data from the preferences. But just for fun set your Launcher Arguments in the launcher to:
    and see if that works. If it does not work, then we will likely have to edit your preferences manually. The easiest way to do this is to download a plist editor such as this, open it and search for unity.Portalarium.Shroud of the Avatar.plist. Once that is open you can search for Resolution and you should see settings for Height and Width - change those to width of 1920 and height 1080.
    [​IMG]
     
  2. Widsith [MGT]

    Widsith [MGT] Avatar

    Messages:
    685
    Likes Received:
    632
    Trophy Points:
    93
    I'll give the launcher params a try. Anything fancier will have to wait until tomorrow - have to get organized for a class I'm teaching this evening...

    BTW, celebration on increased frame rate was premature - most was due to a (side-effect?) change of quality from Auto to Fastest. Forced it back I'm once again at 4-5fps aat the same view.
     
  3. Widsith [MGT]

    Widsith [MGT] Avatar

    Messages:
    685
    Likes Received:
    632
    Trophy Points:
    93
    @Undone The launcher params 'worked', but what it does is force the intial window size to 1920x1080 rather than do any scaling. Video menu then offers that window size plus the whole screen option as in the one above. About to try the same trick with full screen set.

    @Undone With full screen set, the launcher params are ignored and I end up at 2560x1440 with no other menu options.
     
    Last edited: Dec 11, 2017
  4. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    346
    Likes Received:
    848
    Trophy Points:
    43
    Not sure I understand what you mean.
     
  5. Widsith [MGT]

    Widsith [MGT] Avatar

    Messages:
    685
    Likes Received:
    632
    Trophy Points:
    93
    Like so:
    [​IMG]

    Is that what you expected to see? It's not how SotA was behaving pre-R48 (and the new Unity version) - it would use the specified resolution within the bounds of its window, IOW, it scaled.
     
  6. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    346
    Likes Received:
    848
    Trophy Points:
    43
    that looks correct. the video options are obviously not showing the correct thing, but the resolution of the game looks correct at 1920x1080. Perf improvements?
     
  7. Widsith [MGT]

    Widsith [MGT] Avatar

    Messages:
    685
    Likes Received:
    632
    Trophy Points:
    93
    @Undone Eureka! - maybe. I tried setting the 'Open in Low Resolution' flag in the Info window for both the Launcher and the embedded Sota app. That gets a different behavior, which is scaling - but doing it wrong. See the following:

    [​IMG]

    [​IMG]

    Notice that it did come up in a lower resolution, just got it rather wrong - X axis is way too wide. Fonts are also funky. Nonetheless - this is more like how it was behaving pre-R48, just bugged.

    Hypothesis: Unity started 'respecting' the Open in Low Res flag in the last release, but got it somehow wrong. It forces Sota to 'system resolution' if the flag is NOT set - which is how it is behaving in my first screen dumps. If the Low Res flag is set, then it takes what's set in the params, but gets it wrong. (And I have no idea why that should behave differently on your systems than mine. I might give my old MacBook Air a try again just to see what happens - if it doesn't melt...)

    That's all until late tonight or tomorrow.
     
  8. Widsith [MGT]

    Widsith [MGT] Avatar

    Messages:
    685
    Likes Received:
    632
    Trophy Points:
    93
    Some, but of course it's pushing fewer pixels. See my new post for something closer to how it used to behave.
     
  9. Baene Thorrstad

    Baene Thorrstad Avatar

    Messages:
    309
    Likes Received:
    498
    Trophy Points:
    55
    Gender:
    Male
    Location:
    Providence, RI
    Did some testing this evening. So far, I'm not seeing any real difference in performance. Seems about the same FPS with or without metal. I do get some occasional glitches, where a tree will flash white for a frame, or get some odd multi colored patterns on a texture for a frame, but thats about it.

    I did run into one odd issue. My MacBook Pro 15" has both integrated and dedicated graphics. When I first ran the client with metal, the graphics were horribly washed out. After a few attempts and some fiddling I was able to get it to go away by deactivating the automatic graphics switching in System Preferences to force it to use the dedicated graphics.

    System Specs:
    MacOs: 10.13.1
    MacBook Pro (Retina, 15-inch, Late 2013)
    Processor 2.3 GHz Intel Core i7
    Memory 16 GB 1600 MHz DDR3
    Graphics NVIDIA GeForce GT 750M 2 GB / Intel Iris Pro 1536 MB
     
    Last edited: Dec 11, 2017
  10. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    346
    Likes Received:
    848
    Trophy Points:
    43
    I wonder if the OS isn't detecting that it needs to switch for some reason. I typically run this little app on my mbp just so I can see what applications use dedicated/etc (not to mention it allows for quick switching)
     
  11. Widsith [MGT]

    Widsith [MGT] Avatar

    Messages:
    685
    Likes Received:
    632
    Trophy Points:
    93
    @Undone One support for my theory above: Yesterday, I tried going back to R48 and forcing the same resolutions as above (able to do it thru the menu, rather than launcher params) and ended up exactly the same situation with low-res but wrong aspect ratio window. This was WITHOUT Open in Low Res flag set. In QA version I got that effect only when setting the Low Res flag in the finder. I think Unity changed something in how/whether they handle that OS X level setting.
     
Thread Status:
Not open for further replies.