1. We have a QA initiative where we work with the community more closely than ever to get your bug reports into the hands of the developers. Please use this forum for LIVE Server bug reporting. Do follow the format below, because it will help us out greatly in responding. If you do not, it's possible your bug report will be misinterpreted, or worse, lost!

    Read BEFORE submitting your first bug: Reporting Bugs… QA 101 Document
    • Search for your bug before posting in order to avoid duplicate reports.
    • Only reply to an existing thread if you have additional information for the reported bug. ALL extraneous commentary will be deleted to avoid cluttering the reports.
    • Keep your bug report short and factual.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    Bug Report Template
    1. Title:
    2. Reproduction Rate:
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs:
    To get started, use /bug in-game (/devbug if on QA) to auto-create this template. It will even auto-fill some of the required information and open the browser for you. Then take the information that was just saved to your system's clipboard and paste it into a new QA forum post. Thank you bug hunters!
Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Resolved] Unable to purchase from the Crown Store with multiple coto stacks

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Jaesun, Jan 25, 2019.

  1. Jaesun

    Jaesun Avatar

    Messages:
    2,858
    Likes Received:
    3,126
    Trophy Points:
    153
    01/25/2019 11:38
    Title: Unable to purchase homes in the Crown Store
    Reproduction Rate: 2/2
    Blocker? Yes
    Details: With my very small amount of COTO's I was attempting to purchase 2 homes from the Crown Store. I get the prompt "There was a problem during the exchange, and it could not be completed."
    Steps to Reproduce: Try to buy the Stone 2-Story Round Tower Village Home or Kobold Dual Spire Village Home. Of note I DO have the amount of COTO's on me to purchase them (40).
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Xeon(R) CPU E5-1620 0 @ 3.60GHz (8) System RAM: 16303
    GPU: NVIDIA GeForce GTX 1080 GPU RAM: 8079
    SotA.QA.Win.64.798.Date.01.25.19
    Area: Novia_R6_City_Jaanaford
    Area Display Name: Jaanaford
    Loc: (91.0, 15.0, -186.7)
    Debug: Tm92aWFfUjZfQ2l0eV9KYWFuYWZvcmR8fCg5MC45NTMsIDE1LjAwMSwgLTE4Ni42NzUpfCgwLCAtMC45NTUsIDAsIC0wLjI5Nil8NTA1LjcxMDR8MTkuNjUyMjR8MTUuNTIyNjc=

    [​IMG]

    I'll try some others just to see if anything can be bought?
     
  2. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    320
    Likes Received:
    780
    Trophy Points:
    43
    Let us know if this issue continues. I was unable to repro this on 798 so I'm wondering if there was some hiccup along the way.
     
    Jaesun likes this.
  3. Jaesun

    Jaesun Avatar

    Messages:
    2,858
    Likes Received:
    3,126
    Trophy Points:
    153
    I just tried again to buy the kobold house, and could not purchase it. I got the same error message.

    I’ll assume no one else is having this issue?

    Also of note, the icon for the crown store at the top right, doesn’t have a label when hovering the mouse over it. The rest of the icons do have labels.
     
  4. Jaesun

    Jaesun Avatar

    Messages:
    2,858
    Likes Received:
    3,126
    Trophy Points:
    153
    I *think* I figured out WHY this was happening. I had 37 0 value cotos and the 3 with value cotos that I had found since first playing the game, which was a total of 40.

    THAT would not allow me to buy anything (that was a total of 40 COTO's). I removed the 37 0 value cotos to the bank and just had the 3 with value cotos on me. And bought one of the 3 coto portrait packs. THAT worked just fine.

    I then put the 37 cotos I had on hand from the bank with 0 value, put them in my inventory, and then tried to buy the Kobold home. That also worked just fine.

    I *think* a combo of 0 value COTO's AND ones with value are not combined? I did have 40 COTO's in total on me, but they were of different values.

    Curious if anyone else could try to replicate this as well.
     
    Last edited: Jan 26, 2019
  5. Lord Subtleton

    Lord Subtleton SotA Dev Moderator SOTA Developer

    Messages:
    910
    Likes Received:
    1,236
    Trophy Points:
    93
    Thanks for digging into this. Issue #63711

    EDIT: Now resolved.
     
    Last edited: Jan 29, 2019
    Lained and Jaesun like this.