Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Responded] MAC Client hangs machine after a few minutes in Game

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Mactavish, Nov 15, 2018.

Thread Status:
Not open for further replies.
  1. Mactavish

    Mactavish Avatar

    Messages:
    49
    Likes Received:
    20
    Trophy Points:
    8
    Gender:
    Male
    I don't even have enough time to hit BUG before my entire machine locks up.
    Going to try to hit bug and save it to a word doc before the machine locks.
    Will post on this thread if successful. Hopefully its not just me
     
  2. Mactavish

    Mactavish Avatar

    Messages:
    49
    Likes Received:
    20
    Trophy Points:
    8
    Gender:
    Male
    11/15/2018 09:28

    Title: MAC Client hangs machine after a few minutes in game

    Reproduction Rate:100%

    Blocker? YES, 100% unplayable, plus entire machine HANGS!!!!

    Details: Entire Machine HANGS a few minutes into gameplay - Doesn't matter if on Overworld or in a Scene

    Steps to Reproduce:Run the Launcher, login to game

    User Specs:

    OS: Mac OS X 10.14.1

    CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8) System RAM: 32768

    GPU: AMD Radeon R9 M395X GPU RAM: 4096

    SotA.OSX.64.868.Date.11.14.18

    Area: Novia

    Area Display Name: Novia

    Loc: (50.9, 16.8, -367.0)

    Debug: Tm92aWF8fCg1MC44NjgsIDE2Ljc3MiwgLTM2Nyl8KDAuMDAyLCAtMC44NDYsIC0wLjAwOCwgLTAuNTMzKXwxMTUuNTkxOHw0NXwyMA==
     
    Last edited: Nov 15, 2018
  3. Turok64

    Turok64 Avatar

    Messages:
    34
    Likes Received:
    51
    Trophy Points:
    8
    This is my exact bug.

    Has to do with the update i did to my osx?
     
  4. Widsith [MGT]

    Widsith [MGT] Avatar

    Messages:
    665
    Likes Received:
    613
    Trophy Points:
    93
    I am on 10.12, and not seeing this, so may well be OS version dependent.
     
    Mactavish likes this.
  5. Mactavish

    Mactavish Avatar

    Messages:
    49
    Likes Received:
    20
    Trophy Points:
    8
    Gender:
    Male
    I will see if i can roll back the update to 10.14.1 and see if the game becomes playable again.

    CONFIRMED - ROLLED BACK to 10.14 and Game plays Just fine.
     
    Jaesun likes this.
  6. Silberfarn

    Silberfarn Avatar

    Messages:
    67
    Likes Received:
    201
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Germany
    I can confirm this bug, including the meltdown of the whole machine. I reported it during R60 QA. I am on 10.14.1, the game only hitchingly works with "-force-glcore" in the launcher. I hope the team fixes this as a rollback to a less secure OS should not be an option. OsX High Sierra worked like a dream with 40-50 fps, Mojave now is way worse.
    Silberfarn

    @Mactavish: digital buddhism: everything is one, except zero
     
    Mactavish likes this.
  7. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    345
    Likes Received:
    842
    Trophy Points:
    43
    Just tried this on a 10.14.1 machine and encountered a crash after running around for a little while. unfortunately the crash did not give us any helpful information so we will continue to look into it. I have a feeling this is a bug on unity or apple's end. I would recommend trying with -force-glcore and see if the crash continues for now.
     
    Mactavish likes this.
  8. Silberfarn

    Silberfarn Avatar

    Messages:
    67
    Likes Received:
    201
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Germany
    If this is of any help, my impression was that just standing still (Mojave 10.14.1, Metal default) worked. It crashed after I moved around. "-force-glcore" mitigates this issue but makes the game quite hitchy.
     
  9. Camro

    Camro Avatar

    Messages:
    28
    Likes Received:
    42
    Trophy Points:
    3
    Same problem as me - 10.14.1 too
     
  10. Balrod

    Balrod Avatar

    Messages:
    17
    Likes Received:
    8
    Trophy Points:
    3
    +1 (10.14.1)
    Now going on approx. 4 weeks that I can't play this game on my mac. Errors, and bugs, just getting worse and worse. Even with -glcore-force
    Therefore, I'm starting to get used to the idea that I will never be able to play this game on my mac OS, ever again...
    SOTA might as well remove the "MAC OS COMPATIBLE" icons until they get a fix for it.
     
  11. Undone

    Undone Trap Master Moderator SOTA Developer

    Messages:
    345
    Likes Received:
    842
    Trophy Points:
    43
    Make sure that you are using "-force-glcore" and not what you wrote; otherwise the game will still launch with the metal api and you will notice no changes. The game currently works fine on 10.13.x with the metal API so this is either a bug on Unity's end or Apple's. We have reached out to Unity but who knows how long that may take. In the mean time "-force-glcore" should get you going with the unfortunate side effect of worse performance.
     
    Balrod likes this.
  12. Balrod

    Balrod Avatar

    Messages:
    17
    Likes Received:
    8
    Trophy Points:
    3
    You are right, I had typed it reversed, thank you for pointing that out. In the meantime will wait for Unity.
     
Thread Status:
Not open for further replies.