Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Take All not working for containers within containers

Discussion in 'Items & Inventory' started by Spungwa, Jul 27, 2019.

  1. Spungwa

    Spungwa Avatar

    Messages:
    608
    Likes Received:
    1,250
    Trophy Points:
    93
    07/27/2019 11:32
    Title: Take All not working for containers within containers
    Reproduction Rate: 100%
    Blocker? N
    Details:
    When you place a container on a lot and open it you get a "take all" button.
    If you take all from a container then this works.
    If you have a container inside that first container (and this happens for every sub container after the initial container) then using the take all button of teh sub container gives "You do not have permissions to remove items from this container."
    But if I drag the item rather than use the take all it works.
    I'm the owner of the lot, so I should have the permissions. So the nested containers "take all" should allow me.

    Steps to Reproduce:
    Get 3 backpacks (or whatever containers) call then A, B, and C
    Put Backpack C instead backpack B.
    Put backpack B inside backpack A.
    Place backpack A on the ground on a lot you have access to.
    Open backpack A.
    If you do take all - this works - test passed. Backpack B (with Backpack C inside is in your inventory)
    Put backpack B back in backpack A (which is still on the floor of your lot).
    Open backpack B.
    If you do take all - this give the permissions error. #1
    If you drag backpack B to your inventory - this works - test passed. Backpack C is in your inventory. #2
    #1 and #2 are the same operation just using a different input mechanism, they should not give different end results.

    Note 1 : this also does not work with 4 etc. So anything container after the first level the take all gives an incorrect permissions error.

    Note 2 : I tried this with both deco mode on and off, it made on difference. Which is as I would expect. Deco mode only changes for certain stacks if you pick one or all the stack by default, so has no affect on take all.

    Edit : Tested using the ALT-Click method too. This behaves the same as dragging (ie works). Which makes sense as i believe it is a shortcut way of dragging items to your inventory.


    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8) System RAM: 32665
    GPU: NVIDIA GeForce GTX 970 GPU RAM: 4058
    SotA.Win.64.1019.Date.07.26.19
    Area: POT_forest_metropolis_02_template/Crossroads
    Area Display Name: Crossroads
    Loc: (149.4, 44.8, 31.8)
    Debug: UE9UX2ZvcmVzdF9tZXRyb3BvbGlzXzAyX3RlbXBsYXRlfENyb3Nzcm9hZHN8KDE0OS40NDUsIDQ0LjgwNCwgMzEuOCl8KDAsIC0wLjY2LCAwLCAwLjc1MSl8LTEyNC4wNzg2fDQ1LjA2NzM1fDguMjA5OTk2
     
    Last edited: Jul 27, 2019
    OzzyOsbourne likes this.
  2. OzzyOsbourne

    OzzyOsbourne Avatar

    Messages:
    506
    Likes Received:
    497
    Trophy Points:
    63
    Tried to do some brewing today, I hold all the kegs inside a chest and used to be able to loot them upon maturity with the 'take all' button; now it gives me a pop-up saying "You do not have permission to remove contents from this container." I ran down every possibility and moved every container in and out. Changed permissions to every possible setting. Same pop-up.

    The ONLY solution to bypass this issue is to take each keg out and place it as deco and double click and finaly loot 'take all'. The other method is to move them to inventory and individually drag and drop each of the contents of each keg and also be forced to select the amount which is probably another issue in and of itself.

    so obviously,... going to go and pop them in and out as deco to loot them :(