Windowed Mode Question

Discussion in 'General Discussion' started by jmcclain, Apr 5, 2019.

  1. jmcclain

    jmcclain Avatar

    Messages:
    59
    Likes Received:
    61
    Trophy Points:
    8
    I always play in windowed mode and have since i stared the game. However since last release when i click to play in windowed mode it will only allow for minimized window when i click to maximize window it goes full screen not windowed. Anyone have an idea why this is happening or how to fix it?
     
  2. Alley Oop

    Alley Oop Bug Brigade – Bug Hunter

    Messages:
    9,216
    Likes Received:
    14,818
    Trophy Points:
    153
     
  3. jmcclain

    jmcclain Avatar

    Messages:
    59
    Likes Received:
    61
    Trophy Points:
    8
    Thank you
     
    Time Lord and Kaffien like this.
  4. Weins201

    Weins201 Avatar

    Messages:
    7,127
    Likes Received:
    10,968
    Trophy Points:
    153
    Any word on this solution??

    @Chris, @DarkStarr, @BurningToad

    1. [​IMG]
      1. Joined:
      2. Nov 7, 2016
    2. Posts:
    3. 31

    4. Unless I'm mistaken, I think you didn't read correctly the OP's post. Changing resolution while in game in indeed trivial, and so is switching between fullscreen and windowed.

      The issue is swtiching between "Exclusive Fullscreen" and "Windowed fullscreen", which uses a Unity setting that is only available at compile time, not at runtime.

      That being said, I HAVE seen some unity games offer both options. I believe Kingmaker and Pillars Of Eternity 2 both allow the user to choose between "exclusive fullscreen" and "windowed fullscreen" and are using Unity, so there is certainly a way. I suspect they're using custom code to make it happen though.
      Click to expand...
      Apologies, I think I'm confused because the unity doc doesn't seem to match what's going on in my game. I used https://docs.unity3d.com/ScriptReference/FullScreenMode.html and when selecting "ExclusiveFullScreen" it does indeed go exclusive and stuff like GeForce overlay is enabled and it's definitely in exclusive mode. "FullscreenWindow" it goes borderless windowed and you can hit the win key and your start menu appears over the game window but I don't get any Window OS UI. When I select "Windowed" only then does the window max / min / close UI appear.

      I suggest trying it out and see what happens!

    5. GordGames, Apr 12, 2019
    6. #6
    7. SixEyesStudio likes this.
    8. SixEyesStudio
      [​IMG]

      Joined:
      Aug 9, 2017
      Posts:
      9

      Apologies, I think I'm confused because the unity doc doesn't seem to match what's going on in my game. I used https://docs.unity3d.com/ScriptReference/FullScreenMode.html and when selecting "ExclusiveFullScreen" it does indeed go exclusive and stuff like GeForce overlay is enabled and it's definitely in exclusive mode. "FullscreenWindow" it goes borderless windowed and you can hit the win key and your start menu appears over the game window but I don't get any Window OS UI. When I select "Windowed" only then does the window max / min / close UI appear.

      I suggest trying it out and see what happens!
      Click to expand...
      Hah! Very interesting. That actually did the trick!
      It seems like:
      Screen.SetResolution(with, height, true);

      Will use whatever the "Player Settings -> Fullscreen Mode" value is, and that value cannot be changed at runtime, just build time (hence the confusion for some people, myself included).

      Whereas:
      Screen.SetResolution(width, height, FullScreenMode.ExclusiveFullScreen);

      Will correctly use Exclusive full screen, regardless of the "Player Settings -> Fullscreen Mode" value.

      I admit, I had not noticed the call with "FullScreenMode" rather than "bool isFullscreen" in the unity documentation.

      Thanks a lot for the help friend! :)

      SixEyesStudio, Apr 14, 2019
      #7
    I took this off Unities page so is this the fix?????
     
    Time Lord and Kaffien like this.
  5. Mystic

    Mystic Avatar

    Messages:
    971
    Likes Received:
    2,150
    Trophy Points:
    93
    Hopefully this gets fixed soon. I hate being in full screen :(
     
    Time Lord and FrostII like this.
  6. Alley Oop

    Alley Oop Bug Brigade – Bug Hunter

    Messages:
    9,216
    Likes Received:
    14,818
    Trophy Points:
    153
    i can't test myself since it's a windows bug, but have you tried today's release? saw this on discord:

    @Lained Today at 1:21 PM
    Maximize no longer goes full screen. \o/
     
  7. Mystic

    Mystic Avatar

    Messages:
    971
    Likes Received:
    2,150
    Trophy Points:
    93
    YAY! It's fixed! :D
    Thanks for the heads up
     
    Jaesun, FrostII, ErikRulez and 2 others like this.
  8. Nevyn Waldail

    Nevyn Waldail Avatar

    Messages:
    179
    Likes Received:
    256
    Trophy Points:
    18
    it seems to work for me if I snap it to the top of the screen
     
  9. Violet Ronso

    Violet Ronso Avatar

    Messages:
    1,138
    Likes Received:
    2,108
    Trophy Points:
    113
    Yeah now it does, but for the past 2-3 releases when you would snap it up top you would go back to fullscreen.
     
  10. Lazarus Long

    Lazarus Long Avatar

    Messages:
    760
    Likes Received:
    2,168
    Trophy Points:
    93
    Gender:
    Male
    Location:
    New Britannia
    Fixed this past release.

    Dunno if it was an intentional or not, since there is no more option for windowed mode.

    BUT if you d click a small window the game will now open to fit full screen windowed.

    Laz
     
  11. Lained

    Lained Avatar

    Messages:
    2,067
    Likes Received:
    3,471
    Trophy Points:
    165
    Location:
    Yeovil, England
    It was a Unity bug, Options > Full Screen toggles windowed mode.