1. We have a QA initiative where we work with the community more closely than ever to get your bug reports into the hands of the developers. Please use this forum for LIVE Server bug reporting. Do follow the format below, because it will help us out greatly in responding. If you do not, it's possible your bug report will be misinterpreted, or worse, lost!

    Read BEFORE submitting your first bug: Reporting Bugs… QA 101 Document
    • Search for your bug before posting in order to avoid duplicate reports.
    • Only reply to an existing thread if you have additional information for the reported bug. ALL extraneous commentary will be deleted to avoid cluttering the reports.
    • Keep your bug report short and factual.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    Bug Report Template
    1. Title:
    2. Reproduction Rate:
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs:
    To get started, use /bug in-game (/devbug if on QA) to auto-create this template. It will even auto-fill some of the required information and open the browser for you. Then take the information that was just saved to your system's clipboard and paste it into a new QA forum post. Thank you bug hunters!
Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Disappointing release: Hitching unchanged

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Sorthious, Jul 26, 2018.

  1. Sorthious

    Sorthious Avatar

    Messages:
    1,135
    Likes Received:
    1,358
    Trophy Points:
    113
    Details: Hitching was eliminated in the last QA Patch, but is unchanged from r55 in Live.

    User Specs:
    OS: Linux 4.15 Ubuntu 18.04 64bit
    CPU: Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz (4) System RAM: 15913
    GPU: AMD Radeon (TM) RX 480 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.0-29-generic, LLVM 6.0.0) GPU RAM: 8161
    SotA.Linux.64.811.Date.07.25.18
    Area: The Rise
    Area Display Name: The Rise
    Loc: (72.0, 40.0, 113.7)
    Debug: VGhlIFJpc2V8fCg3MS45NjgsIDQwLjAwNSwgMTEzLjY2OSl8KDAsIC0wLjk5OCwgMCwgMC4wNjYpfC0xMDkuNzI4NHwyNS4zMzM0NHw0LjY5ODM0
     
    By Tor, Feeyo and Alley Oop like this.
  2. Chris

    Chris Tech Lord Moderator SOTA Developer

    Messages:
    2,243
    Likes Received:
    25,663
    Trophy Points:
    190
    Gender:
    Male
    Definitely should see the same result on live as QA. We did a fair amount of cleanup to remove allocations and reduce shader compiles so should be better but not 100% fixed.
     
    Sorthious likes this.
  3. liz_the_wiz

    liz_the_wiz Bug Brigade - Bug Hunter

    Messages:
    1,143
    Likes Received:
    1,840
    Trophy Points:
    113
    Gender:
    Female
    For me, the pause on mob spawn is also back with a vengence..
     
    Sorthious likes this.
  4. Sorthious

    Sorthious Avatar

    Messages:
    1,135
    Likes Received:
    1,358
    Trophy Points:
    113
    @Chris , I thought that it would be, but as soon as I logged in, was in Yew, and hitching was immediate. In QA patch 724, I didn't notice any hitching at all. Granted, I only played for about 15mins but I went to scenes where the hitching was generally pretty bad in r55 and it was totally hitch free. Something between QA and Live has changed the performance. Maybe it's something to do with networking, the server load, or the server itself(provided it isn't run on the same server)? Anyway, something between QA/Live is causing the hitching. Also, I tried lowering the video settings to Fastest and cut off Volumetric Lighting and everything that wasn't necessary. Thanks for the fast response! Here is a video I did during r55, this is how the hitching was then, and now.



    If there are any tests you need me to run I'm more than happy to help find the issue. Also, hopefully others with the same issue will post more info.
     
    Feeyo, Jaesun and Mishikal like this.
  5. Jaesun

    Jaesun Avatar

    Messages:
    2,500
    Likes Received:
    2,676
    Trophy Points:
    153
    Yeah even in offline mode I still have some hitching. It isn’t as bad as the previous releases though.
     
  6. Mishikal

    Mishikal Avatar

    Messages:
    1,402
    Likes Received:
    1,976
    Trophy Points:
    113
    Location:
    Brittany Estates
    apparently some due to the weather. Have you tried 813?
     
    Jaesun likes this.
  7. Jaesun

    Jaesun Avatar

    Messages:
    2,500
    Likes Received:
    2,676
    Trophy Points:
    153
    Not yet, I got called into work today. Will download in a few minutes when I get home.

    Edit: With 813 Holy Crap!!!! This runs really smooth now. Even in combat. Still get a bit of hitching when walking around.
     
    Last edited: Jul 26, 2018
    Feeyo and Mishikal like this.
  8. Chris

    Chris Tech Lord Moderator SOTA Developer

    Messages:
    2,243
    Likes Received:
    25,663
    Trophy Points:
    190
    Gender:
    Male
    Hitching should be better but not completely gone with this release. As always though, our goal is to just make sure each release is better than the last one!
     
  9. Steevodeevo

    Steevodeevo Avatar

    Messages:
    1,238
    Likes Received:
    2,314
    Trophy Points:
    113
    @Chris, for me its marginally better generally, especially in Scenes and Over World but still pretty rough in NPC Towns, and not just during the initial load up. I was in Two of the Brittany towns shopping earlier (Fields & Estates) and it actually seemed a little worse :(
     
  10. Sorthious

    Sorthious Avatar

    Messages:
    1,135
    Likes Received:
    1,358
    Trophy Points:
    113
    There was nothing mentioned in the Patch Notes for 813 that addressed hitching. Regardless, I tried 813 and it's exactly the same. I get the same or worse amount of hitching when compared with r55.

    I understand that you are trying to make the hitching/performance better with each release but that just isn't what I'm experiencing. For me, r56 is the same or worse than r55. I'm interested to know of others are getting the same type of performance as I am. The main thing I don't understand is why performance was so good in Patch 724 on QA and is so horrible on Live. That perfomance was so good on 724QA tells me that it is at least possible for me to be hitch free(or near enough to it.) Right now the hitching is nearly unbearable.
     
    Nog and Feeyo like this.
  11. Steevodeevo

    Steevodeevo Avatar

    Messages:
    1,238
    Likes Received:
    2,314
    Trophy Points:
    113
    add Owls Head to that... I couldn't live there.
     
    Sorthious and Feeyo like this.
  12. Steevodeevo

    Steevodeevo Avatar

    Messages:
    1,238
    Likes Received:
    2,314
    Trophy Points:
    113
    Player numbers would be my guess? I can enter a scene and be the only player and my performance is sublime. Add one player and I start to stutter, add two or three and its a hitching situation. That said player data transfer isn't all of the problem. I entered a busy zone today and switched to Party mode (solo) and I still had some hitching.
     
    Sorthious and Feeyo like this.
  13. Mishikal

    Mishikal Avatar

    Messages:
    1,402
    Likes Received:
    1,976
    Trophy Points:
    113
    Location:
    Brittany Estates
    This item:

    * Improved some weather effects

    Is what I was referring to. There was a bit of discussion on Discord that weather was enabled for scenes that don't even have weather (like say The Rise) that was causing performance issues.
     
    Sorthious likes this.
  14. Feeyo

    Feeyo Avatar

    Messages:
    1,487
    Likes Received:
    2,169
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Yes I am having the same hitching as in R55 at least on my Linux box. :(
    I will update my windows SotA client later on and test if this is the same on Windows.
     
    Sorthious likes this.
  15. Sorthious

    Sorthious Avatar

    Messages:
    1,135
    Likes Received:
    1,358
    Trophy Points:
    113
    Ok, but does this refer to Quality of weather effects or weather effects effect on performance. The Patch notes didn't make any reference to performance improvements. As I said, regardless of what it was intended to do, I tested patch 813 and it, for me at least, made no discernable difference from patch 812 in regards to hitching.
     
  16. By Tor

    By Tor Avatar

    Messages:
    2,297
    Likes Received:
    4,690
    Trophy Points:
    165
    Gender:
    Male
    Location:
    Baton Rouge, Louisiana, USA
    I had high hopes about the hitching problem from the feedback during QA. Unfortunately, it's definitely still present. I think it may be slightly better than last release... but not by much. Reducing video settings helps but doesn't eliminate it.
     
    Jaesun and Sorthious like this.
  17. Sorthious

    Sorthious Avatar

    Messages:
    1,135
    Likes Received:
    1,358
    Trophy Points:
    113
    Yes, this is pretty much what I'm suspecting is going on. It may be do to the increased server load, a networking issue or a problem with the server itself. Whatever the issue, the corrections that worked on QA aren't translating to the Live server. However, I'm not sure that the amount of players that i'm directly playing with is relevant, as my issues are experienced entirely while playing solo and in Party Mode.

     
  18. Sorthious

    Sorthious Avatar

    Messages:
    1,135
    Likes Received:
    1,358
    Trophy Points:
    113
    The only thing that changed for me by lowering setting was my framerate increased. The hitching doesn't seem to care whether i'm using Best or Fastest settings, whether I have High shadows or none at all, or whether I have reflections set to high or low.
     
  19. By Tor

    By Tor Avatar

    Messages:
    2,297
    Likes Received:
    4,690
    Trophy Points:
    165
    Gender:
    Male
    Location:
    Baton Rouge, Louisiana, USA
    I'm scratching my head at what could be causing the hitching then.
     
    Feeyo and Sorthious like this.
  20. Sorthious

    Sorthious Avatar

    Messages:
    1,135
    Likes Received:
    1,358
    Trophy Points:
    113
    As I said:

    Not sure what the problem is, but I'm hoping this gets addressed quickly, because I don't see this release as being even slightly better than the last release. In r55 it took a couple mins before the hitching kicked in. Now, it's immediate. I'm hardly playing at all anymore, only because this is the 3rd release where the hitching is ruining gameplay. I love the game, when it is working, but right now it isn't, for me at least. I'm sure I'm not the only person who is fed up with this issue. You can add as many cool things to the game as you want, but if a player is hitching every 3-5s they will get sick of it and stop playing. I'm on the verge of that right now. Hopefully this will be taken seriously and they will figure out why they can get nearly flawless performance(which I had for QA Patch 724) on QA, and virtually no change on Live.
     
    Nog, Jaesun, Feeyo and 1 other person like this.