Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Disappointing release: Hitching unchanged

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Sorthious, Jul 26, 2018.

Thread Status:
Not open for further replies.
  1. the Lacedaemonian

    the Lacedaemonian Avatar

    Messages:
    297
    Likes Received:
    451
    Trophy Points:
    28
    It doesn't help. The issue is that Unity leaves no room for anything else to use graphics memory. So you gotta lower the amount of fps the graphics card can produce.
     
    Mishikal likes this.
  2. Mishikal

    Mishikal Avatar

    Messages:
    1,964
    Likes Received:
    2,832
    Trophy Points:
    113
    Location:
    Brittany Estates
    Maybe they were thinking of this person. Although that is 3, not 2. ;)
     
  3. Mishikal

    Mishikal Avatar

    Messages:
    1,964
    Likes Received:
    2,832
    Trophy Points:
    113
    Location:
    Brittany Estates
    Thanks, I found the link to the tool, but it took a while. :)
     
  4. Mishikal

    Mishikal Avatar

    Messages:
    1,964
    Likes Received:
    2,832
    Trophy Points:
    113
    Location:
    Brittany Estates
    Ah, my graphics card is MSI rebundled so I can use their afterburner program to do this via RivaStatistics Server. :)
     
    the Lacedaemonian likes this.
  5. Feeyo

    Feeyo Avatar

    Messages:
    1,677
    Likes Received:
    2,466
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    I have a decent rig, with 32GB RAM and 8GB of GPU RAM, I constantly have hitching... from the start when I launch SotA.
    What did help a little bit is disabling HyperThreading.
     
    Sorthious and the Lacedaemonian like this.
  6. the Lacedaemonian

    the Lacedaemonian Avatar

    Messages:
    297
    Likes Received:
    451
    Trophy Points:
    28
    I have a card with 6gb onboard memory, and 4 gb shared (laptop full sized 1060). Shroud never uses the shared, but before I did this FPS hard cap, I would be hitching near-constantly after 3-6 zone changes. Now, after the cap, I haven't hit FPS below 100 as long as I have tested.

    Yet, I still watch my video memory slowly balloon, it just hasn't happened to fill up all available since I've done this. I'll know more after extensive gaming during double XP.
     
  7. Feeyo

    Feeyo Avatar

    Messages:
    1,677
    Likes Received:
    2,466
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    So they should set this on the unity build settings then:
    https://docs.unity3d.com/ScriptReference/Application-targetFrameRate.html
     
    Sorthious and Sentinel2 like this.
  8. Feeyo

    Feeyo Avatar

    Messages:
    1,677
    Likes Received:
    2,466
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Just force 30fps through unity and disable QualitySettings.vSyncCount so that we can enable/disable vsync on our own machines if wanted.
     
    Sorthious and the Lacedaemonian like this.
  9. Feeyo

    Feeyo Avatar

    Messages:
    1,677
    Likes Received:
    2,466
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    If anyone on GNU/Linux wants to test out if it really fixes it when capping the framerate. (I am currently on vacation and do not have access to my game rig).
    Code:
    git clone https://gitlab.com/torkel104/libstrangle.git
    cd libstrange
    make && sudo make install
    cd to your SotA directory
    sudo ldconfig
    export XMODIFIERS=""; VSYNC=1 strangle 30 ./Shroud\ of\ the\ Avatar.x86_64
     
    the Lacedaemonian likes this.
Thread Status:
Not open for further replies.