[PELICAN]

Discussion in 'Release 33 Bug Forum' started by Beolthain, Aug 30, 2016.

  1. Beolthain

    Beolthain Avatar

    Messages:
    55
    Likes Received:
    151
    Trophy Points:
    20
    Gender:
    Male
    Location:
    Finland
    1. Title: [PELICAN] Network congestion caused a disconnection from the game service
    2. Reproduction Rate: 100 %
    3. Blocker? Hell yes!
    4. Details: Everywhere, except in overland and in Ardoris I get "Potential network trouble" icon and shortly I get disconnected.
    5. Steps to Reproduce: Login, go to any area, wander about and get disconnected
    6. User Specs: Win10 64-bit, i7-3610QM @ 2.3 GHz, 16 Gb memory, Nvidia GeForce GTX660M.
    Multiplayer online. Now it doesn't disconnect as fast as in release 32.
     
    Time Lord, crydee, narcosis and 3 others like this.
  2. Attenwood

    Attenwood Associate Producer SOTA Developer

    Messages:
    6,603
    Likes Received:
    5,081
    Trophy Points:
    153
    Thank you for reporting. We're looking into this issue.
     
    Time Lord and Nataurz like this.
  3. Nhili Dragon

    Nhili Dragon Avatar

    Messages:
    165
    Likes Received:
    149
    Trophy Points:
    18
    Gender:
    Female
    Location:
    Colorado, USA
    I keep getting dropped with this notice also am in friends online and trying clink quest.:eek:
    This was the last day (so far) that it happened.
     
    Last edited: Sep 6, 2016
  4. Mykll

    Mykll Avatar

    Messages:
    326
    Likes Received:
    524
    Trophy Points:
    55
    Gender:
    Male
    Location:
    Davidian Bunker
  5. Nataurz

    Nataurz Avatar

    Messages:
    85
    Likes Received:
    232
    Trophy Points:
    8
    Please fix this issue as it is very very annoying.
     
    Time Lord, Hornpipe, Mykll and 2 others like this.
  6. Ihuma

    Ihuma Avatar

    Messages:
    111
    Likes Received:
    529
    Trophy Points:
    30
    Gender:
    Male
    Location:
    Owl's Head
    Having the same issues. Only started today. Nothing has changed in terms of my internet, location or computing device.
     
    Time Lord and Hornpipe like this.
  7. Beolthain

    Beolthain Avatar

    Messages:
    55
    Likes Received:
    151
    Trophy Points:
    20
    Gender:
    Male
    Location:
    Finland
    Still having this. Logged in at Highvale and instant logoff.
     
    Time Lord likes this.
  8. Gregg247

    Gregg247 Avatar

    Messages:
    110
    Likes Received:
    246
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Lake Cusabo and Fallin' Green
    I don't know what's going on with SotA tonight, but I've been kicked out of the game with PELICAN errors constantly over the past hour. This happened in Whiteguard Foothills as well as the overland map. The "network performance" error pops up in the upper right hand corner of my screen for about 20-30 seconds, and then I'm out. It was running fine a few hours ago.

    I had this same problem a couple of weeks ago in Ardoris. I couldn't enter that city without having this problem all weekend, then it just cleared up.
     
    Beolthain, Time Lord and Hornpipe like this.
  9. Hornpipe

    Hornpipe Avatar

    Messages:
    690
    Likes Received:
    1,619
    Trophy Points:
    93
    Same here. I was in a party in Eastreach Gap and everything was fine until we group with someone else. As the instance was closing, we had to quit Eastreach Gap and return. As soon as I did that, "network performance" was popping around every second in the upper right hand corner with big LAGS until I got the PELICAN error. I've tried to log in after that both with Steam client then without it, no way to get ride of the network poor performance.

    (Multiplayer Online)
     
    Kliirkast, Beolthain and Time Lord like this.
  10. Hornpipe

    Hornpipe Avatar

    Messages:
    690
    Likes Received:
    1,619
    Trophy Points:
    93
    A short video of the lag problem which occures, sometimes, since few weeks and especially those two last days. It can be worse than that but it's a good exemple.



    This time, I had no disconnection. The problem is generaly occuring after joining a big party (6+) in my case.
     
    Last edited: Sep 16, 2016
    Kliirkast, Beolthain and Time Lord like this.
  11. Nataurz

    Nataurz Avatar

    Messages:
    85
    Likes Received:
    232
    Trophy Points:
    8
    I have discovered a common theme to having the pelican disconnects. If I zone into Central Brittany and see the network trouble symbol I check if anyone else is in the zone and it is always empty. I then keep attempting to log in and continue having the pelican disconnect until there is someone else in the zone. As long as 1 other person in in the zone I do not have network issues, as soon as they leave and I am the only one in the zone it immediately returns and I get disconnected. I can only assume the first person into Central Brittany hosts the zone ? and as I am only on asdl 2 and from Australia my net can not return info fast enough or upload/download info fast enough. I hope this gives you something to work with @Attenwood
     
    Beolthain and Time Lord like this.
  12. Nataurz

    Nataurz Avatar

    Messages:
    85
    Likes Received:
    232
    Trophy Points:
    8
    To add to this I did a further test. I had a mate on NBN internet zone into Central Brittany , I then zoned in and had no connection issue. A third person then zoned into Central Brittany. We wanted to test if each zone is hosted by the order you entered. My mate who was first to enter left Central Brittany and I immediately had the network issue icon appear and I then pelican dced 20 or so seconds later. So we can assume you take over host of a zone by the order you enter. My mate zoned back in and waited for the third person to leave. As soon as they left the network issue icon appeared briefly but then disappeared.
     
    Beolthain and Time Lord like this.
  13. Hornpipe

    Hornpipe Avatar

    Messages:
    690
    Likes Received:
    1,619
    Trophy Points:
    93
    I'm not sure there is a zone hosting system involved in this. I think the hardest thing to do in the netcode is to keep synchronisation between all players in one instance, server-side. When a player who has a 120 ms ping (120 ms to upload the input + download the output) encounter other players with 80 ms ping, then other players with 100 ms ping, the soft must ensure to keep them on the same timeline. If the lag comes from a faulty sync between particular profiles, it won't be easy to reproduce it. For my part, when I'm in Eastreach Gap, lag appears when a new player enter the instance and join our party. And it's very annoying.
     
    Beolthain and Time Lord like this.
  14. Scanphor

    Scanphor Avatar

    Messages:
    42
    Likes Received:
    75
    Trophy Points:
    8
    Same issue here - I can only rarely play in multiplayer as a result (single player online works 90% of the time). Seems to be anywhere - the client either just hangs at "Equipping avatars 100%" or I get the dreaded [Pelican] message.

    I'm in rural Scotland on a slightly suspect ADSL connection but good enough to play lots of other MMOs which are playing fine at the same time I can't get into SOTA.

    Happy to provide any further details on my connection / trace etc - Its a reasonably high end PC so client performance is never an issue.
     
    Beolthain likes this.
  15. Beolthain

    Beolthain Avatar

    Messages:
    55
    Likes Received:
    151
    Trophy Points:
    20
    Gender:
    Male
    Location:
    Finland
    I agree with disconnections when you are the only person in scene. Sometimes it helps when i stare the ground. Then the network issue icon goes away.

    I am on 10/2 adsl and located in rural Finland. Never had a problem with mmos or SotA before Release 32.
     
    Nataurz likes this.
  16. Hornpipe

    Hornpipe Avatar

    Messages:
    690
    Likes Received:
    1,619
    Trophy Points:
    93
    This !

    I'm not in a rural zone plus I'm 600m from the DSLAM.
     
  17. Lord Subtleton

    Lord Subtleton SotA Dev SOTA Developer

    Messages:
    284
    Likes Received:
    491
    Trophy Points:
    28
    Hornpipe,
    Thank you for posting - particularly the video. I've collected a bunch of logging information from that recent game session and sent it to the programmers for their review.
     
    Mykll, Nataurz and Hornpipe like this.
  18. Hornpipe

    Hornpipe Avatar

    Messages:
    690
    Likes Received:
    1,619
    Trophy Points:
    93
    You're welcome ! I'm very pleased if this is useful !

    As you noticed, this video is from yesterday (9pm47 UTC Paris time). Also, you could have a lot of interesting informations with my play session which stood the day before this one. (with pelican disconnection). Unfortunately I didn't recorded that one. :(

    Smash this damn bug *toast* ;)
     
    Last edited: Sep 16, 2016
    Nataurz likes this.
  19. Peabo

    Peabo Avatar

    Messages:
    268
    Likes Received:
    681
    Trophy Points:
    28
    The video shows lagging problems, however it doesnt show anything to do with Pelican disconnects.
    I've tested with other players experiencing Pelican disconnects "That are related to entering large cities (Central Brittany) and can confirm that if im the first player inside the city, they do NOT experience Pelican disconnects.
    I will add that im not in group with these players.
    If I leave the city and they stay behind - They will be instantly disconnected with Pelican; this is only for players that experience pelican disconnects and have slower internet speeds and would be the next inline to host.
    If someone is in zone before I enter and then they leave after I've entered, I get a potential network issue for around 20 seconds. I assume this is because im now hosting the city.
    I have very fast internet!
    I can test this further by having an alt account host the city and you might see a massive decrease of Pelican disconnects in Central Brittany, however I wouldnt want to risk my account being banned for "obvious afk macroing" that would be required to stop it logging out.

    I beleive that all large cities should be hosted by a Portalium server and not by players with slow connections, as this might be the only internet they can access.

    @Attenwood @Atos @Lord British @Darkstar

    Please contact me if you would like to test more
     
    Last edited: Sep 16, 2016
  20. Hornpipe

    Hornpipe Avatar

    Messages:
    690
    Likes Received:
    1,619
    Trophy Points:
    93
    You are perhaps right : the two bugs may not be related, but my lag sometimes cause PELICAN disconnections as the one you described. That's why I posted here.

    Anyway, I don't believe SOTA instances are hosted by players. The best reason is that it could be open way for cheating. IMHO, what you observe is probably caused by server code or client sync problems.

    I encourage you to provide details of the relevant playing sessions (date, mates'name, etc).