1. We have a QA initiative where we work with the community more closely than ever to get your bug reports into the hands of the developers. Please use this forum for LIVE Server bug reporting. Do follow the format below, because it will help us out greatly in responding. If you do not, it's possible your bug report will be misinterpreted, or worse, lost!

    Read BEFORE submitting your first bug: Reporting Bugsā€¦ QA 101 Document
    • Search for your bug before posting in order to avoid duplicate reports.
    • Only reply to an existing thread if you have additional information for the reported bug. ALL extraneous commentary will be deleted to avoid cluttering the reports.
    • Keep your bug report short and factual.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    Bug Report Template
    1. Title:
    2. Reproduction Rate:
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs:
    To get started, use /bug in-game (/devbug if on QA) to auto-create this template. It will even auto-fill some of the required information and open the browser for you. Then take the information that was just saved to your system's clipboard and paste it into a new QA forum post. Thank you bug hunters!
Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

[Responded] Disappearing vendor after placement

Discussion in 'Player Owned Towns & Player Housing' started by Duke Vallas [BEAR], May 6, 2018.

  1. Duke Vallas [BEAR]

    Duke Vallas [BEAR] Avatar

    Messages:
    666
    Likes Received:
    2,984
    Trophy Points:
    93
    1. Title: Disappearing vendor after placement
    2. Reproduction Rate:At least 1 instance
    3. Blocker? Yes
    4. Details:I placed a commission-free vendor at my plot in Beran's Reach (town-sized, the High Rock Brewery, directly opposite the main bank), at which point 'Bernard the Tavern Vendor' disappeared. I see him reappear just left of the current vendor, 'tellen arms and armour' after logging in, but only for a split second. I suspect this might be a wider issue, so reporting it as well as helping for a hand on this.
    5. Steps to Reproduce: Unsure, how I simply placed the vendor. I was at the edge of the plot on placing, so that may be a factor.
    6. User Specs: -
     
  2. Lexie

    Lexie Bear Queen

    Messages:
    839
    Likes Received:
    2,901
    Trophy Points:
    93
    Can you please do a /bug at the location please? I'd like to at least take a look.
    Also please email support@portalarium.com this information so they can look at this as missing item (account relating) issue.
    Very strange.
    @Duke Vallas
     
  3. Thief

    Thief Avatar

    Messages:
    81
    Likes Received:
    106
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Istanbul
    @Lexie

    Here is a youtube video :) Just happened to me as well.


     
  4. Lexie

    Lexie Bear Queen

    Messages:
    839
    Likes Received:
    2,901
    Trophy Points:
    93
    @Ferohir
    /bug so we can get the coords please. Video is awesome but the exact spot is what we need
     
  5. Thief

    Thief Avatar

    Messages:
    81
    Likes Received:
    106
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Istanbul
    Title:
    Reproduction Rate:
    Blocker?
    Details:
    Steps to Reproduce:
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8) System RAM: 16327
    GPU: NVIDIA GeForce GTX 980 Ti GPU RAM: 6097
    SotA.Win.64.773.Date.05.01.18
    Area: POT_forest_metropolis_01a_template/Beregost
    Area Display Name: Beregost
    Loc: (130.1, 38.0, 168.9)
    Debug: UE9UX2ZvcmVzdF9tZXRyb3BvbGlzXzAxYV90ZW1wbGF0ZXxCZXJlZ29zdHwoMTMwLjEyNiwgMzcuOTk3LCAxNjguODc4KXwoMCwgLTAuNzU1LCAwLCAwLjY1Nil8MjYxLjk3MzF8MTB8My4zMzAyNjc=
     
    Lexie likes this.
  6. Duke Vallas [BEAR]

    Duke Vallas [BEAR] Avatar

    Messages:
    666
    Likes Received:
    2,984
    Trophy Points:
    93
    My vendor returned, however there seemed to be no logic to it and it wasn't after a single restart.
     
  7. Thief

    Thief Avatar

    Messages:
    81
    Likes Received:
    106
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Istanbul
    I restarted, changed the instance did not help. It appear by itself about 30 mins later.
     
    Lexie likes this.
  8. Lexie

    Lexie Bear Queen

    Messages:
    839
    Likes Received:
    2,901
    Trophy Points:
    93
    Stickying this thread in case we get more clues to this 'mystery'
    Is this happening to any others out there?
     
  9. Toff

    Toff Avatar

    Messages:
    102
    Likes Received:
    224
    Trophy Points:
    18
    Location:
    Kingsport
    Ok, so this just happened to me too. I have 2 lots next to each other and this is what I found....I'll use Lot A and Lot B.

    I removed my vendor from Lot A into inventory

    I tried placing vendor on Lot B, it appeared for a split second then disappeared. I found the vendor back on Lot A where I removed it from.

    While standing on Lot A I could interact with the vendors menu but I could not pick it up. Logging in and out or changing scenes did not help.

    Then...here is where it gets really weird, While Standing on Lot B next door I was able to grab the vendor off Lot A and place in inventory again.

    Then I really screwed up because I also have another lot in town we'll call Lot C. Like a complete moron I tried placing the vendor on that and you guessed it....the vendor jumped back to Lot A again, but this time the lots are too far apart so I can't stand on Lot C and see the vendor on Lot A to pick him back up.


    I hope this made sense.

    Toff
     
  10. Toff

    Toff Avatar

    Messages:
    102
    Likes Received:
    224
    Trophy Points:
    18
    Location:
    Kingsport
    Follow up.... The last Lot I tried placing the vendor on was Lot C, but of course the vendor jumped back to Lot A, however.....If I property manage and store Lot C the vendor is removed from Lot A then when I restore Lot C the vendor re-appears on Lot A gain. I'll let you fine people make sense of this :)
     
  11. Toff

    Toff Avatar

    Messages:
    102
    Likes Received:
    224
    Trophy Points:
    18
    Location:
    Kingsport
    Follow up to my follow up :)

    I got my vendor back. So the last lot I tried placing the vendor in was Lot C, he popped back to Lot A. then I stored Lot C in property manager, the vendor disappeared from Lot A when I did this. Then I waited about 10 minutes and restored Lot C and the vendor was there on Lot C where I tried to place him and I picked it up. Seams like some sort of Lag issue.

    Anyway, I hope this helped more than it confused :)