Unplayable Performance in Party Mode

Discussion in 'General Discussion' started by Nog, Jul 16, 2018.

Thread Status:
Not open for further replies.
  1. Nog

    Nog Avatar

    Messages:
    156
    Likes Received:
    217
    Trophy Points:
    18
    Location:
    126 N State St., Mishawaka, IN 46544
    I'm curious if anyone has insight or shares this experience. My settings for the game are under-set to medium-low. My rig (gpu/processor/memory) is significantly above the required specs and I have a tested 11M/sec internet connection. In solo play I don't see choppy framerates (except in certain towns) - though SotA does not have anywhere near the awesome sharp framerates I get in, say, Neverwinter or WoW or Tera or pretty much any other game.

    But the second I play in a party my performance usually becomes so bad as to make the game unplayable (eg. swinging at enemies that have moved away, trying to use evasive maneuvers but the delay makes it futile, etc.). It's always been this way for me, especially when a lot of enemies fill up a room. How common is this experience in party mode? While there are a couple of other major dissatisfactions I have (deck system), this one is the biggest that has prevented me from logging in - as terrible game performance isn't worth fighting with.
     
    Last edited: Jul 22, 2018
    Azzamean likes this.
  2. Azzamean

    Azzamean Avatar

    Messages:
    105
    Likes Received:
    197
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Kentuckiana
    Get a better machine. =)
     
    Lord Trady of Blix likes this.
  3. Alley Oop

    Alley Oop Bug Hunter Bug Moderator

    Messages:
    11,267
    Likes Received:
    16,468
    Trophy Points:
    153
    if you find there's a significant difference in performance in party mode between when you're the first one in the scene (the one to create the instance) and when you're coming into one already created, it's a matter of the scenemaster not having a good machine and/or connection. is there someone you're regularly playing with that's especially far away or has especially slow internet? don't let that guy create the instance.
     
  4. Nog

    Nog Avatar

    Messages:
    156
    Likes Received:
    217
    Trophy Points:
    18
    Location:
    126 N State St., Mishawaka, IN 46544
    This doesn't seem to be the case here...in at least some cases the person setting the instance has the new hyper-speed internet (70M/sec+) and lives in the same city/county.
     
    Solazur and Alley Oop like this.
  5. Nog

    Nog Avatar

    Messages:
    156
    Likes Received:
    217
    Trophy Points:
    18
    Location:
    126 N State St., Mishawaka, IN 46544
    Any others experience bad performance in party mode? I'm trying to determine if this is: (a) not enough internet speed, (b) an oddity that affects people randomly despite excellent system specs, (c) a regular game issue that might one day go away with better optimization.

    After all, super bad framerate due to fighting in party mode is a pretty big deal for game viability.
     
  6. DeadnGone

    DeadnGone Avatar

    Messages:
    601
    Likes Received:
    794
    Trophy Points:
    93
    Yeah could be all sorts of issues. Could be the hitching issue with parties. Could be the machine's hardware. Could be a need to optimize your computer, etc. What's your system specs?
    I've got an older rig but I can tweak it and optimize it for gaming most stuff no problem at all and higher graphics (though you'll still get better visuals with newer cards):
    GTX 760 with 12GB RAM
    i7-4770 @3.40GHz (8 CPUs/4 really)
    Win 10 in both FS/Windowed mode
    I don't have any problems with the game running in highest settings. Or my other rigs, maybe a bit slower on my children's as they are even older. Wife's is much better than mine and another rig is about the same with a GTX 770.

    Heard some people have issues with "peripheral lighting" checked. I haven't had that issue though I use razer chroma keyboard/mice and wife uses same as well as her case lighting, haven't seen any issues with it. There have been issues with other operating systems, do you use Linux?

    It may really come down to simply doing a cleansing of your machine, updating drivers, getting rid of any background TSRs (usually using something like Razer's Cortex gaming utility) to run before launching the game, if you have an Nvidia card, something like GeForce Experience to optimize settings, any other cleaning (anti-virus/malware/bloatware, etc) and use tools like Glary's Utilities, CCleaner, etc to check/fix registry, clear cache, etc etc all followed by a clean reboot before playing your game (and even after a little while).

    There are still some memory leaks after a while, not bad as it used to be, but some areas, like doing Upper Tears for me and my wife, I'll have to reboot after 6hrs of AoE hell... sometimes after 8hrs or so if i've done a lot of vendor shopping, especially heavily populated/dense areas like the Brittany suburbs. I pretty much have to reboot after doing vendor shopping and before doing dungeon romps/group runs or i'll be severely choppy. Also, if you're video driver settings reset/get defaulted and it lets the computer choose or its not set for the video card to run/takeover... it can cause all sorts of issues as well.

    So it could be any of these things, but sounds like it may be the hitching problem up above that others have been having. I haven't seen it yet (knock on wood). Hope you get it sorted out.
     
    Nog and Solazur like this.
  7. Nog

    Nog Avatar

    Messages:
    156
    Likes Received:
    217
    Trophy Points:
    18
    Location:
    126 N State St., Mishawaka, IN 46544
    amd R9 200 series
    16gb ram
    i7-4790 (x8)
    win10

    Not only are the graphics and windows drivers up to date, I did a reinstall on the OS (twice). The performance is the same as before in group play: extreme choppiness, inability to target enemies effectively, slow unresponsive movement. No graphics or lag problems in other games I play...thus my surprise the game runs absolutely awfully in party mode.

    In single play I can set the graphics to a high setting, though find the game responsiveness a bit sharper when running on "simple" or "good." And bigger player owned towns can be (but are not always) laggy and choppy no matter the graphics setting.

    What this has led to is backing away from the game so long as this issue is ongoing. I got through nearly all of the quests and finished the Shroud quest, which leaves mostly grindy stuff to do and grouping with the party/guild - except grouping due to this problem is brutally unfun.
     
    Last edited: Jul 22, 2018
    Brugas likes this.
  8. Anpu

    Anpu Bug Hunter

    Messages:
    5,541
    Likes Received:
    6,177
    Trophy Points:
    153
    Location:
    Pacific Northwest
    The hitching still happens in solo instances.
     
    Sorthious and discipleofweb like this.
  9. DeadnGone

    DeadnGone Avatar

    Messages:
    601
    Likes Received:
    794
    Trophy Points:
    93
    Yeah player towns and housing will always do that... especially in heavier populated areas. Been like that in gaming ever since Ultima Online, Star Wars Galaxies, etc. Anytime an area has a ton of specially placed objects that's not static on your harddrive/game area, its gotta load all that stuff in every time and every 50-100 feet or so, yeah gonna be choppy but at least you get to have that level of housing and decor in a game.

    As far as party mode, I can concur... something with the leader or the one who who starts and instance... if they are laggy, having issues, etc, then I can have no problems whatsoever... but the mobs look like their rubberbanding and messing it up for the party. Leave and reform party, and it seems to be fixed. Not sure what they can do about it as long as the mechanic is in place that runs an instance based on the one who started it... seems like a horrible idea to me. Had something like that in early Conan Exiles as well which was annoying and I couldn't play it like that.
     
    Nog and Lord Trady of Blix like this.
  10. Floors

    Floors Avatar

    Messages:
    4,271
    Likes Received:
    6,623
    Trophy Points:
    165
    I have bad play occassionally in party mode, but usually it's okay. It's never quite as nice as a private instance, but ti's not borderline unplayable 95 percent of the time.

    I have a 1000/300 fiber connection. An R580 with 8GB. 64 GB Ram. Mac.

    Even with that performance is bad at times, in towns mainly (Ardoris is one of the worst). It has gotten better in the last couple releases.

    Sota regularly will play with like 15-25 frames per second in scenes like Blood River, etc.
     
    Nog likes this.
  11. Manticore2

    Manticore2 Avatar

    Messages:
    2
    Likes Received:
    4
    Trophy Points:
    3
    This game doesn't have a budget like those other games. How much did it cost to make Neverwinter, or WoW, or Tera?
     
  12. Talimar

    Talimar Avatar

    Messages:
    78
    Likes Received:
    65
    Trophy Points:
    8
    I've got a cheapish video card and the easiest performance boost for chop is to reduce shadows at the moment.

    Upper tears performance is horrible compared to every other party-kill area so if you are doing that them that is your largest issue. I can't heal in upper tears because of something wrong with the scene.

    (Even set to fastest. Hopefully r56 will improve this.)
     
    Nog likes this.
  13. DeadnGone

    DeadnGone Avatar

    Messages:
    601
    Likes Received:
    794
    Trophy Points:
    93
  14. Nog

    Nog Avatar

    Messages:
    156
    Likes Received:
    217
    Trophy Points:
    18
    Location:
    126 N State St., Mishawaka, IN 46544
    I mean, sure the budget for SotA is far less than WoW. That provides little consolation when it comes to deciding to spend my leisure hours dealing with unplayable performance, though. This (performance, not budget) is the deal breaker for me until the technical issue (hitching?) is eliminated through future development.
     
    Last edited: Jul 26, 2018
  15. Anpu

    Anpu Bug Hunter

    Messages:
    5,541
    Likes Received:
    6,177
    Trophy Points:
    153
    Location:
    Pacific Northwest
    I was just playing on the current test server version and the hitching was gone for me (as well as many others). I think they might have figured out what was causing that.
     
    Barugon, Sorthious and Nog like this.
  16. Floors

    Floors Avatar

    Messages:
    4,271
    Likes Received:
    6,623
    Trophy Points:
    165
    I had some bad hitching early on testing R55 and in the first couple releases but since 805 its not bad. But that hitching is perhaps unrelated to the party scene issues in tears, in the obsidian memories in the lost vale, etc.
     
    Nog likes this.
  17. Barugon

    Barugon Avatar

    Messages:
    13,689
    Likes Received:
    21,276
    Trophy Points:
    153
    Gender:
    Male
    Hitching is not completely gone for me. There's still significant hitching while a scene loads but once that's done, it's smooth action from there on.
     
    Jaesun likes this.
  18. Anpu

    Anpu Bug Hunter

    Messages:
    5,541
    Likes Received:
    6,177
    Trophy Points:
    153
    Location:
    Pacific Northwest
    Yeah, other than first entering an area, and while it is loading, I still get a hitch. But after that, I haven’t seen it hitch at all. Im going to go play in east vauben foothills and see if that is all hitch free (other than entering it)....

    Also there’s a missing entrance.....
     
  19. Nog

    Nog Avatar

    Messages:
    156
    Likes Received:
    217
    Trophy Points:
    18
    Location:
    126 N State St., Mishawaka, IN 46544
    I have no feeling whatsoever that a 20-30M lower budget game isn't worth my time. I hope the hitching issue will be fixed with future patches soon, as I don't think it's an absurdly high expectation for group play to be basically smooth-ish and functional on my system. SotA has many good elements within it, evident by how many hours I played in solo play.
     
    Last edited: Jul 25, 2018
Thread Status:
Not open for further replies.