1. We have a QA initiative where we work with the community more closely than ever to get your bug reports into the hands of the developers. Please use this forum for LIVE Server bug reporting. Do follow the format below, because it will help us out greatly in responding. If you do not, it's possible your bug report will be misinterpreted, or worse, lost!

    Read BEFORE submitting your first bug: Reporting Bugs… QA 101 Document
    • Search for your bug before posting in order to avoid duplicate reports.
    • Only reply to an existing thread if you have additional information for the reported bug. ALL extraneous commentary will be deleted to avoid cluttering the reports.
    • Keep your bug report short and factual.
    • There is no need to submit crash logs. Crash data we require is automatically logged.
    Bug Report Template
    1. Title:
    2. Reproduction Rate:
    3. Blocker?
    4. Details:
    5. Steps to Reproduce:
    6. User Specs:
    To get started, use /bug in-game (/devbug if on QA) to auto-create this template. It will even auto-fill some of the required information and open the browser for you. Then take the information that was just saved to your system's clipboard and paste it into a new QA forum post. Thank you bug hunters!
Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Hitching/Freezes

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Feeyo, Aug 30, 2018.

  1. Feeyo

    Feeyo Avatar

    Messages:
    1,624
    Likes Received:
    2,399
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    08/30/2018 18:56
    Title: Hitching/Freezes
    Reproduction Rate: 100%
    Blocker? Kinda
    Details: When running around, fighting the game freezes for a moment and then continues. I upgraded my GPU card from a AMD RX580 to a GTX 1080. Same problem. Currently running Windows to see if I can reproduce it as on my GNU/Linux system. And yes I can confirm it is also hitching.
    Steps to Reproduce:Run around killing skellies and Liches.
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-3960X CPU @ 3.30GHz (6) System RAM: 32718
    GPU: NVIDIA GeForce GTX 1080 GPU RAM: 8086
    SotA.Win.64.822.Date.08.29.18
    Area: HiddenVale_Forest02_Tier5
    Area Display Name: Deep Ravenswood
    Loc: (-43.4, 46.1, -59.6)
    Debug: SGlkZGVuVmFsZV9Gb3Jlc3QwMl9UaWVyNXx8KC00My40MjYsIDQ2LjA3MSwgLTU5LjYyNyl8KDAsIDAuMDYyLCAwLCAtMC45OTgpfC0zNjYuOTEyNHwzLjUzMDA4NXw4LjExMzMzOA==


    [​IMG]
    [​IMG]
     
  2. Sorthious

    Sorthious Avatar

    Messages:
    1,136
    Likes Received:
    1,360
    Trophy Points:
    113
    I didn't think they could get much worse than r56, but I stand corrected. The hitching starts almost immediately! I took video of QA Patch 734 and r56 right before release and here is a comparison. I will try to do a new video for r57 when I get a chance.

    Edit: I suppose it would help to actually leave the link:

    QA Patch 734 and Release 56 performance comparison
     
    Last edited: Aug 30, 2018
  3. GrayFog

    GrayFog Avatar

    Messages:
    674
    Likes Received:
    1,402
    Trophy Points:
    93
    Yup it got worse for me too now in r57
     
    Sorthious likes this.
  4. Chris

    Chris Tech Lord Moderator SOTA Developer

    Messages:
    2,334
    Likes Received:
    26,647
    Trophy Points:
    190
    Gender:
    Male
    Investigating this now. Expect to see Atos running around The Rise shortly. :)
     
  5. Gia2

    Gia2 Avatar

    Messages:
    263
    Likes Received:
    558
    Trophy Points:
    28
    Gender:
    Male
    Hitching almost everywhere here for me as well.
    FPS is almost always at vsync lock. RAM is free. Game is on SSD. background processes are strictly under control.

    09/03/2018 18:27
    Title:
    Reproduction Rate:
    Blocker?
    Details:
    Steps to Reproduce:
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i5-4670K CPU @ 4.00GHz (4) System RAM: 16262
    GPU: NVIDIA GeForce GTX 1080 GPU RAM: 8079
    SotA.Win.64.825.Date.08.31.18
    Area: Novia_R2_Hills01_CragFoothills
    Area Display Name: Crag Foothills
    Loc: (33.0, 70.4, -177.9)
    Debug: Tm92aWFfUjJfSGlsbHMwMV9DcmFnRm9vdGhpbGxzfHwoMzMuMDQ0LCA3MC40MywgLTE3Ny44NTcpfCgwLCAwLjExLCAwLCAwLjk5NCl8MzcyLjg1MDd8MTQuNTU4NzN8Ni44NzUyMzc=
     
    Feeyo and Sorthious like this.
  6. Sentinel2

    Sentinel2 Avatar

    Messages:
    875
    Likes Received:
    1,447
    Trophy Points:
    93
    Surprising.

    When I was testing on the QA server, hardly any issue with hitching. That was even the night before release. I'm curious what changed from Wednesday to the Thursday release.
     
    Sorthious likes this.
  7. hulahula

    hulahula Avatar

    Messages:
    3
    Likes Received:
    3
    Trophy Points:
    3
    09/22/2018 00:43
    Title:
    Reproduction Rate:
    Blocker?
    Details:
    Steps to Reproduce:
    User Specs:
    OS: Linux 4.18 ManjaroLinux 17.1.12 64bit
    CPU: Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz (12) System RAM: 28038
    GPU: GeForce GTX 1070 Ti/PCIe/SSE2 GPU RAM: 8192
    SotA.Linux.64.830.Date.09.07.18
    Area: Novia_R7_Forest02_01
    Area Display Name: Fluss des Blutes Stadtrand
    Loc: (116.0, 66.2, 186.2)
    Debug: Tm92aWFfUjdfRm9yZXN0MDJfMDF8fCgxMTYuMDE2LCA2Ni4yMzQsIDE4Ni4yNDcpfCgwLCAtMC4yMzgsIDAsIDAuOTcxKXwtOTcuNTEyMDR8NDIuMzc4NjN8NC43MDgzNg==
     
  8. Feeyo

    Feeyo Avatar

    Messages:
    1,624
    Likes Received:
    2,399
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    I lately play sota with vsync disabled, I am not seeing any tearing and hitches are less then with vsync enabled on my system.
     
    Sorthious and Sentinel2 like this.
  9. Feeyo

    Feeyo Avatar

    Messages:
    1,624
    Likes Received:
    2,399
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Ok so I now am almost 100% sure the hitching is because of SotA's internal vsync. As SotA forces vsync to always be On. I even saw some jumps from BLIT to FLIP. I am not happy with this.

    Can you devs please add a vsync enable/disable toggle to SotA? I would prefer to disable vsync in SotA and use the drivers AMD/nvidia vsync.

    Also as most of the players have vsync on their gpu card enabled per default, meaning we now have 2 vsync systems fighting each other.

    Thank you in advance.
     
    Last edited: Sep 25, 2018
    Sentinel2 and Arradin like this.
  10. Feeyo

    Feeyo Avatar

    Messages:
    1,624
    Likes Received:
    2,399
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Mishikal likes this.
  11. Sentinel2

    Sentinel2 Avatar

    Messages:
    875
    Likes Received:
    1,447
    Trophy Points:
    93
    Feeyo likes this.
  12. Sorthious

    Sorthious Avatar

    Messages:
    1,136
    Likes Received:
    1,360
    Trophy Points:
    113
    I manually cut off vsync for my card. It doesn't seem to be trying to coordinate vsync with my monitors refresh rate of 60Hz. Maybe I'm misunderstanding how this works, but I thought that vsync would cap my FPS to the refresh rate of my monitor. So, 60FPS in my case. In fact, this is what happens when I enable vsync on my video card. Again, maybe I'm misunderstanding this or overlooking something crucial to what you are saying.
     
  13. Feeyo

    Feeyo Avatar

    Messages:
    1,624
    Likes Received:
    2,399
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Yes vsync tries to match the max fps to your monitors refresh rate (60Hz = 60fps). If your fps goes higher without vsync enabled it will cause screen tearing. VSync is great when the frame rate exceeds the monitor’s refresh rate. But if you come to a heavy graphically scene, and the frame rate drops below the refresh rate, the graphics card will drop it down further to best match the monitor’s preferences (could be a big step to 30Hz). The result is an even bigger drop stutter or hitch in frame rate in those moments.
    And as Sota has vsync enabled in the client itself, I have a feeling that this is causing the extreme hitching, at least for me.

    Also the performance of vsync of game engines can be poor, I think its best to leave this to the real GPU driver developers and the possibility for us players at least to have it as an "optional" option. We can always tinker with it from our driver settings.
     
    Last edited: Sep 25, 2018
    Sorthious, Sentinel2 and Mishikal like this.
  14. Feeyo

    Feeyo Avatar

    Messages:
    1,624
    Likes Received:
    2,399
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    PS: The forum is pretty unstable lately?
     
  15. Mishikal

    Mishikal Avatar

    Messages:
    1,910
    Likes Received:
    2,688
    Trophy Points:
    113
    Location:
    Brittany Estates
    Do you mean something like getting notifications days or weeks late? Because I've seen that.
     
  16. Feeyo

    Feeyo Avatar

    Messages:
    1,624
    Likes Received:
    2,399
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    No the forum and website just disappears from the internet. And then a few seconds later its online again.

    Code:
    503 Service Unavailable
    No server is available to handle this request. 
     
    Last edited: Sep 25, 2018
    Sorthious likes this.
  17. Sentinel2

    Sentinel2 Avatar

    Messages:
    875
    Likes Received:
    1,447
    Trophy Points:
    93
    I've seen that happen a few times in the last week. Had to refresh the page a few times before it responded.
     
    Mishikal likes this.
  18. Sorthious

    Sorthious Avatar

    Messages:
    1,136
    Likes Received:
    1,360
    Trophy Points:
    113
    I've noticed that sometimes pages take a really long time to load, while other pages load up just fine.
     
    Feeyo likes this.
  19. Sentinel2

    Sentinel2 Avatar

    Messages:
    875
    Likes Received:
    1,447
    Trophy Points:
    93
    It happened again last night.

    I also noticed after messing around on the QA server, I went to the prod system and couldn't login or touch the patch system. For a couple minutes.
     
    Sorthious likes this.
  20. Jaesun

    Jaesun Avatar

    Messages:
    3,207
    Likes Received:
    3,514
    Trophy Points:
    153
    Since I now basically live in the lower area of Upper Tiers, one thing I have consistently observed is when in combat mode, if I am in an area that has no creatures around me, I don’t get any hitching.

    As soon as I head off to creatures, and they start spawning in, the hitching starts up, and during combat with them.

    Is this also what people are noticing? I could make a video showing this.