Dismiss Notice
This Section is READ ONLY - All Posts Are Archived

Severe hitching

Discussion in 'Critical Issues (Blockers, Performance, Crashes)' started by Barugon, Jun 30, 2018.

Thread Status:
Not open for further replies.
  1. Barugon

    Barugon Avatar

    Messages:
    12,155
    Likes Received:
    19,263
    Trophy Points:
    153
    Gender:
    Male
    06/30/2018 01:31
    Title: Severe hitching.
    Reproduction Rate: ?
    Blocker? No.
    Details: Since R54 there is severe hitching. This is not because of scene loading. It happens periodically and when it hits, it slows the game to like one FPS for several seconds (sometimes the game completely halts). There was so much complaining about it in the feedback forum last release that I thought you all would've done something about it but I guess that isn't the case.
    Steps to Reproduce: It really is just a matter of playing the game because it happens everywhere.
    User Specs:
    OS: Linux 4.17 unknown 64bit
    CPU: AMD Ryzen 7 1700 Eight-Core Processor (16) System RAM: 32157
    GPU: GeForce GTX 1070/PCIe/SSE2 GPU RAM: 8192
    SotA.Linux.64.799.Date.06.29.18
    Area: POT_island_metropolis_01_template/Mystic Isle
    Area Display Name: Mystic Isle
    Loc: (19.7, 89.0, -71.8)
    Debug: UE9UX2lzbGFuZF9tZXRyb3BvbGlzXzAxX3RlbXBsYXRlfE15c3RpYyBJc2xlfCgxOS42OTcsIDg5LjAwMywgLTcxLjc1Myl8KDAsIDAuMzE0LCAwLCAtMC45NDkpfC03MjQuMzEwOXwxMy4xNzcxNXw2LjU1NTU3NA==

    [edit] I put that it's not a blocker but the game is largely unplayable due to this.
     
  2. DarkStarr

    DarkStarr Executive Producer Moderator SOTA Developer

    Messages:
    6,684
    Likes Received:
    45,560
    Trophy Points:
    202
    Gender:
    Male
    bug entered, investigating
    60465
     
    Sorthious, Barugon and Jaesun like this.
  3. Feeyo

    Feeyo Avatar

    Messages:
    1,647
    Likes Received:
    2,416
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    This bug happens on GNU/Linux and Windows. With the below specs.
    It happens more frequently the longer I play, also to state it is not scene specific.
     
    Jaesun, Barugon and Sorthious like this.
  4. kaeshiva

    kaeshiva Avatar

    Messages:
    2,501
    Likes Received:
    9,690
    Trophy Points:
    153
    Gender:
    Female
    I've experienced the 'hitching' issue intermittently since well before persistence.
    Some releases, its gone almost completely away
    Others, its back with a vengeance.
    For R55, I'd say its happening, but its not as annoying as it has been in the past, but annoying enough to notice.
    Typically what I'll see is everything is fine, and then I'll 'freeze' for a fraction of a second - if I'm midway through turning my camera it looks like skipped frames.

    Code:
    OS: Windows 10  (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz (8) System RAM: 32619
    GPU: NVIDIA GeForce GTX 1060 3GB GPU RAM: 2988
    
    You can actually see this phenomenon around the 12 second mark in the video I made for the recent royal garden contest - panning camera but you see it 'skip' a few frames, due to a hitch. This one was pretty minor so didn't re-record that segment, though did have to do many segments repeatedly as a result of more severe hitches.


    I appreciate this is a pretty deco-heavy scene, and I can say I do notice the hitching more in towns where there is more player stuff than I do in adventure scenes, although it does happen there, too. Particularly annoying during combat.
     
    By Tor, Jaesun and Sorthious like this.
  5. Sorthious

    Sorthious Avatar

    Messages:
    1,136
    Likes Received:
    1,361
    Trophy Points:
    113
    07/03/2018 12:22

    Reproduction Rate:100%


    Details: I have terrible hitching which gets progressively worse and there is also bad lag. The game even seems to hitching while loading. My monitoring in the picture below will freeze up(hitch) and stop reporting FPS/CPU/GPU stats,etc., for a bit then continue. In the pic I have a 70% GPU Load just standing still, yet the GPU is only using 2.184GBs of VRAM. If there is any more information I can supply to help clear this up I'm more than happy to supply it.

    [​IMG]

    User Specs:
    OS: Linux 4.15 Ubuntu 18.04 64bit
    CPU: Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz (4) System RAM: 15913
    GPU: AMD Radeon (TM) RX 480 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.0-24-generic, LLVM 6.0.0) GPU RAM: 8157
    SotA.Linux.64.800.Date.07.02.18

    Area: Novia
    Area Display Name: Novia
    Loc: (397.3, 15.0, -7.0)
    Debug: Tm92aWF8fCgzOTcuMjc5LCAxNC45NjIsIC03KXwoMC4wMDIsIC0wLjg0NiwgLTAuMDA4LCAtMC41MzMpfC0yMC40NjM4N3wzNi40NTYxfDIw
     
    Jaesun and Feeyo like this.
  6. Arcanoxer

    Arcanoxer Avatar

    Messages:
    408
    Likes Received:
    747
    Trophy Points:
    55
    Gender:
    Male
    Location:
    rl
    Same here, hitching is almost always present for me.
    For years... so i stopped reporting.

    User Specs:
    OS: Linux 4.15 Ubuntu 18.04 64bit
    CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (8) System RAM: 32109
    GPU: GeForce GTX 970/PCIe/SSE2 GPU RAM: 4096
    SotA.Linux.64.801.Date.07.03.18
    Area: Novia_R6_City_Resolute
    Area Display Name: Resolute
    Loc: (-35.6, 78.7, -209.7)
    Debug: Tm92aWFfUjZfQ2l0eV9SZXNvbHV0ZXx8KC0zNS41NzcsIDc4Ljc0MiwgLTIwOS43MzIpfCgwLCAtMSwgMCwgMCl8LTE1OTQuOTEzfDQ0LjY5MzY4fDEuODAyNzY0


    edit: 06.07.18

    07/06/2018 02:26
    OS: Linux 4.15 Ubuntu 18.04 64bit
    CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (8) System RAM: 32109
    GPU: GeForce GTX 970/PCIe/SSE2 GPU RAM: 4096
    SotA.Linux.64.801.Date.07.03.18
    Area: Novia_R7_Forest02_01
    Area Display Name: Blood River Outskirts
    Loc: (330.3, 85.4, 208.9)
    Debug: Tm92aWFfUjdfRm9yZXN0MDJfMDF8fCgzMzAuMjU1LCA4NS4zNywgMjA4LjkxKXwoMCwgLTAuODgzLCAwLCAtMC40NjkpfC0yNjQuMjUzNXwyMC42MzQ3M3w1LjExNDE2Ng==
     
    Last edited: Jul 5, 2018
    Feeyo and Sorthious like this.
  7. Arya Stoneheart

    Arya Stoneheart Avatar

    Messages:
    1,322
    Likes Received:
    2,109
    Trophy Points:
    113
    I also have hitching in both online and offline modes.

    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz (4) System RAM: 16326
    GPU: AMD Radeon R9 200 Series GPU RAM: 4072
     
    Feeyo and Sorthious like this.
  8. Anpu

    Anpu Avatar

    Messages:
    3,666
    Likes Received:
    4,081
    Trophy Points:
    153
    Constant hitching for me since R54.

    NVidia Graphics Card (with the latest drivers)
    Windows 10 64 bit
    Intel(R) Xeon(R) CPU E5-1620 0 @ 3.60GHZ
    16GIGS Ram

    Can post specific when I get home from work.
     
    Last edited: Jul 5, 2018
    Feeyo and Sorthious like this.
  9. Arcanoxer

    Arcanoxer Avatar

    Messages:
    408
    Likes Received:
    747
    Trophy Points:
    55
    Gender:
    Male
    Location:
    rl
    Blood River Outskirts is a extreme hitching example for me.

    User Specs:
    OS: Linux 4.15 Ubuntu 18.04 64bit
    CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (8) System RAM: 32109
    GPU: GeForce GTX 970/PCIe/SSE2 GPU RAM: 4096
    SotA.Linux.64.801.Date.07.03.18
    Area: Novia_R7_Forest02_01
    Area Display Name: Blood River Outskirts
    Loc: (346.4, 81.7, 215.0)
    Debug: Tm92aWFfUjdfRm9yZXN0MDJfMDF8fCgzNDYuMzUxLCA4MS43MjgsIDIxNS4wMDYpfCgwLCAtMC40NzksIDAsIC0wLjg3OCl8LTEwMzEuMTYyfDIyLjMyOTA4fDUuNjI0Njg1
     
    Feeyo and Sorthious like this.
  10. Mishikal

    Mishikal Avatar

    Messages:
    1,966
    Likes Received:
    2,835
    Trophy Points:
    113
    Location:
    Brittany Estates
    I have terrible hitching in The Rise. I only do the mage room and kitchen. (I don't xp other scenes currently, so I can't say if they have the same problem). Definitely worse in R55, was bad in R54 as well.

    07/06/2018 07:12
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (8) System RAM: 32705
    GPU: NVIDIA GeForce GTX 980 GPU RAM: 4053
    SotA.Win.64.801.Date.07.03.18
     
    Feeyo and Sorthious like this.
  11. Sentinel2

    Sentinel2 Avatar

    Messages:
    986
    Likes Received:
    1,627
    Trophy Points:
    93
    Same here. Since R54 it's back for me. R55 did improve. What I see is events seem to slow down for a few seconds before gameplay returns to normal. I've been experimenting to see if I can identify where it's coming from. Testing different modes, video / audio settings and so on.

    So far nothing has presented itself as to why it's happening.

    CPU, Memory, Network utilization are all fine. Even with the latest patch of of the game. It has improved a little since R54 but not dramatically. Specs below.
     
    Sorthious likes this.
  12. Mishikal

    Mishikal Avatar

    Messages:
    1,966
    Likes Received:
    2,835
    Trophy Points:
    113
    Location:
    Brittany Estates
    Feeyo and Sorthious like this.
  13. Bertruger

    Bertruger Avatar

    Messages:
    0
    Likes Received:
    1
    Trophy Points:
    2
    ++++ Linux mint, gtx 970, 16 ram, amd fx 4100 megahertz, very bad game (((
     
    Feeyo likes this.
  14. Feeyo

    Feeyo Avatar

    Messages:
    1,647
    Likes Received:
    2,416
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    07/08/2018 21:49
    Title:
    Reproduction Rate:100%!!
    Blocker?Yes
    Details: Unplayable, pissing me off BIGTIME
    Steps to Reproduce:Farm a few hours
    User Specs:
    OS: Windows 10 (10.0.0) 64bit
    CPU: Intel(R) Core(TM) i7-3960X CPU @ 3.30GHz (12) System RAM: 32718
    GPU: Radeon RX 580 Series GPU RAM: 8137
    SotA.Win.64.802.Date.07.06.18
    Area: HiddenVale_Forest02_Tier5
    Area Display Name: Deep Ravenswood
    Loc: (-4.3, 25.3, -168.1)
    Debug: SGlkZGVuVmFsZV9Gb3Jlc3QwMl9UaWVyNXx8KC00LjMwNywgMjUuMzI4LCAtMTY4LjEyNyl8KDAsIC0wLjA5OSwgMCwgMC45OTUpfC0zMC42Mzk1M3wxMS4wMTMyNXw0LjM2MTM0Mg==
     
    Sorthious likes this.
  15. Mishikal

    Mishikal Avatar

    Messages:
    1,966
    Likes Received:
    2,835
    Trophy Points:
    113
    Location:
    Brittany Estates
    As far as I can tell, it has nothing to do specifically with activity. I.e., I can be doing crafting or farming or XPing, and the hitching is there. Last night, I was sitting idle between runs of the mage room in the rise, and the game would noticeably hitch as well. You could tell when it was occurring by how the visuals for certain spells would just freeze during the hitching, and then continue their usual movement (light spell IIRC).
     
    Feeyo and Sorthious like this.
  16. Sorthious

    Sorthious Avatar

    Messages:
    1,136
    Likes Received:
    1,361
    Trophy Points:
    113
    Mine starts hitching almost immediately and is really bad. The hitching is like every 5-8secs now. Today, 7-8-18, is the worse so far. I'm hitching everywhere; towns, hunting, my basement,etc. It got so annoying I had to log for a while. :mad:
     
    Feeyo likes this.
  17. Barugon

    Barugon Avatar

    Messages:
    12,155
    Likes Received:
    19,263
    Trophy Points:
    153
    Gender:
    Male
    @DarkStarr
    Here's a short video showing the problem:
     
    Sorthious, Arcanoxer, Jaesun and 3 others like this.
  18. Feeyo

    Feeyo Avatar

    Messages:
    1,647
    Likes Received:
    2,416
    Trophy Points:
    113
    Location:
    Aelasar’s Forest
    Yes @Barugon that is exactly my experience also. I will also try to make a video these days. Maybe we could also post our in game video settings. I will incorporate those in the video
     
    Sorthious, Barugon and Jaesun like this.
  19. Sorthious

    Sorthious Avatar

    Messages:
    1,136
    Likes Received:
    1,361
    Trophy Points:
    113
    Yep. That's me like every 5-8secs. The slideshow effect for me gets even worse the longer I play; up to 3+secs before it goes back to being smooth.
     
    Arcanoxer, Feeyo, Jaesun and 2 others like this.
  20. Mishikal

    Mishikal Avatar

    Messages:
    1,966
    Likes Received:
    2,835
    Trophy Points:
    113
    Location:
    Brittany Estates
    Same here. That video was actually fairly generous. ;)
     
    Arcanoxer and Feeyo like this.
Thread Status:
Not open for further replies.